All Refreshes fail without indicating reason

Status: Accepted
by sabinek Occasional Visitor on ‎12-10-2018 12:59 AM

Hello everyone,

 

I have setup four datasets with schedueled refreshes (each once a day on different times). The first few days they all work well and all of a sudden they fail without any reason:

image.png

 

Manual refreshes in the power BI portal succeed (sometimes also the schedueld refresh the next day) but then the refreshes fail again

I had a MS consultant looking at it but his advices (recreate the DB connection and reconfigure the refreshes) did not resolve the problems on a long term.

 

Here also some of the most important information about the circumstances:

Is the data source in Azure or on premises with gateway?
It is an Azure SQL database for three data sets (alwas the same db) and once an application insigts of an azure web app.
Is the problem only with one data source?
No, besides the 3 error messages for datasets based on this Azure SQL DB, the same error message occurred in parallel for a data source based on Applications Insights.
Has the problem occurred several days in a row or by chance?
The first time and also now the initial error message occurs randomly. The error repeats itself with every refresh until the Scheduled Refresh is disabled by the system. When I reactivate it, it works for some days (a week?) and then fails again.
Does the problem always occur on certain days?
As mentioned above, on each refresh, once the error occurred.
If you then restart the refresh manually, does it work?
The manual refresh works and sometimes the scheduled refresh works the next day, but then it fails again.
Here you can see the history of one dataset:
image.png
One more hint: It doesn't seem to depend on the number of refresh runs, but on the duration:
I restarted the Scheduled Refreshs for all 4 datasets on 29.11. One refresh ran twice a day and all others only once. All 4 datasets started to throw error messages on the 4.12.
 
If there is anyone who can help with that problem, I would be very glad.
 
Thanks in advance!
Status: Accepted
Comments
by Moderator v-yuezhe-msft
on ‎12-10-2018 10:31 PM

@sabinek,

Some similar issues have been reported internally. And the fix for the issue will be deployed by 12/15. Please check if schedule refresh works well after 12/15.

Regards,
Lydia

by Moderator v-yuezhe-msft
on ‎12-10-2018 10:31 PM
Status changed to: Accepted
 
by DirkFrazier Frequent Visitor
‎12-14-2018 05:32 AM - edited ‎12-14-2018 05:39 AM

I'm having a similar issue with several of my data sets. https://www.screencast.com/t/FKacswm3Z1 I get an error message however: "Caonnot connect to the mashup data source" - but it doesn't say why it can't connect.

  

Occasionally when the auto-refresh fails, the following on-demand refresh will also fail (almost immediately). Then the second on-demand refresh succeeds. Sometimes the auto-refresh succeeds. Nothing else has changed between refreshes.

 

I'm using the Enterprise Gateway installed on a stand-alone VM (nothing else is running on that VM) which pulls data (via HTTPS) from two SQL databases also running on a single, different VM. Both of the failing Power BI Datasets have the same configuration and connection to the same SQL databases. I'd LOVE to know if the failure to "...connect to the mashup data source..." is because of something timing out or losing touch with the VMs, but I have no idea how to troubleshoot that from the Enterprise Gateway logs. Are there any other tools that would help explore the connections between all these moving parts?

 

It's driving me crazy and I'm not a fan of having to baby sit this process. I hope the 12/15 "fix" works for me as well, but I'm not holding my breath. Smiley Wink

by sabinek Occasional Visitor
on ‎12-17-2018 07:09 AM

I've checked the refreshs after the weekend and it looks good.

Most of them have been working 4 times in a row from Friday up to today.

Only the one from applications insights failed yesterday but completed successfully today.