cancel
Showing results for 
Search instead for 
Did you mean: 

Adding member to row level security hanging

When adding a new member to a row level security group, the loading ring animates for a very long time after pressing Save. After quite a while I get this message:

Activity ID: cf3a9dca-9b48-4e6e-9808-c5aeaded0cc5
Request ID: 710513b4-0fe1-2375-f39f-7989cabec872
Correlation ID: 199e0412-c3bc-23a7-9754-7fc83ba86134
Status code: 500
Time: Mon Jan 11 2021 23:08:13 GMT+0100 (Central European Standard Time)
Service version: 13.0.15101.44
Client version: 2012.4.04418-train
Cluster URI: https://wabi-north-europe-redirect.analysis.windows.net/

Status: New
Comments
v-chuncz-msft
Community Support

@TorbenKirkWolf 

 

You may keep an eye on the Awareness.

Power BI customers with premium capacities using Row Level Security may experience issues while adding non-mail-enabled security groups to roles with the message, "The Role could not be updated. Please try again later". As a workaround, users can move their workspace to Shared, add the security group, then move it back to the capacity. Engineers have identified the root cause and a fix is expected to be deployed by end-of-day 01/16/2020.

TorbenKirkWolf
Advocate I

Thanks for your swift reply, @v-chuncz-msft. It's nice to know that a fix is right around the corner 🙂

zuheirashraf17
Advocate I

We really need new information on these. We've been patiently waiting for this to be fix since 8th January when we discover this issues. Deployment has been held back due to this issue. Please provide a new estimation date so this can be passed on. 

adhulipalaexp
Regular Visitor

Same Issues with my Client as well. unable to add users to the security and deployment is on hold for the past few weeks 

DinaSims98
Regular Visitor

Still experiencing row level security issues when adding a new user. It worked fine ten days ago. What happened?  The proposed work around is not a viable solution. 

DinaSims98_0-1611207373856.png

When will this issue be resolved?

AnonymousPerson
Helper II

The workaround worked for me. But this issue happened for internal email-enabled users -- not just external guest users. Adding users to RLS roles just hung for several minutes before I gave up.