cancel
Showing results for 
Search instead for 
Did you mean: 

Adding Security groups to Row Level Security security settings still has issues

Power BI customers with premium capacities using Row Level Security may experience issues while adding non-mail-enabled security groups to roles with the message, "The Role could not be updated. Please try again later". As a workaround, users can move their workspace to Shared, add the security group, then move it back to the capacity. Engineers have identified the root cause and a fix is expected to be deployed by end-of-day 01/16/2021.

 

Above issue is still not fixed .

Status: New
Comments
saintsitive
New Member

Confirmed that this issue still persists, hope they notice and will fix it soon 😞

YoungChoi
New Member

We are still experiencing this issue as well. Thanks to those that have posted already. Im surprised to read that the issue was posted on the support page and then removed. Not sure why they removed it if the issue has yet to be resolved.

 

v-lili6-msft
Community Support

hi  all

I check the power bi deployments, it is complete for most clusters.

and I have tested on my side, it works well.

 

and for usrs still have problem, if you are use guest user for rls?

9.JPG

 

https://powerbi.microsoft.com/en-us/support/

 

 

Regards,

Lin

saintsitive
New Member

Excuse me, what do you mean by guest user? I'm adding user with same domain company name as mine but still not working. I want to do the workaround option but have no idea how. Please someone explain, I don't know how long I'm allowed to wait for this issue to be solved. Thank you in advance.

ThomasFS
Regular Visitor

We are adding guest users to RLS, which is still not working. However, I just tested with internal users as well, as @v-lili6-msft claim that now works. That still does not work for us either. (EDIT: It actually just added an internal user - just kept processing for 5 minutes. It used to be more or instantly saved)

I agree with @saintsitive - please elaborate on that workaround. What is meant by moving workspace to shared and moving it to capacity? I have tried google it, but did not get any more clarification from that.

PBIWizard
New Member

Please fix this, this is impacting the business!

zuheirashraf17
Advocate I

So just an update, it was working on our side since yesterday. However the time it took to save the group into role took longer time than before which previously almost instant.

ThomasFS
Regular Visitor

For those of you interested, we figured out how the workaround method works, allowing to add both internal and external users to the dataset instantly:

1. In Power BI Online/Service, go to workspaces -> locate the relevant workspace -> select "Workspace settings".

2. Turn off "Premium Capacity" and hit "Save".

ThomasFS_0-1611232537468.png

3. Now we could add and save internal and external users to the RLS. However, if nothing is done further, users will have to have premium/premium trial to view. To avoid this:

3.1 Go back to workspace settings and tick "Premium Capacity" to "on".

 

This workaround at least worked for us. Hope it will help others as well.

YoungChoi
New Member

@ThomasFS wanted to confirm that this workaround worked for us as well. 

DinaSims98
Regular Visitor

@ThomasFS This work around will NOT work for us.  We should be able to add users to row level security without issue.  The questions i have are: What caused this and why has it not been corrected?