Showing results for 
Search instead for 
Did you mean: 

Adding Security groups to Row Level Security security settings still has issues

Power BI customers with premium capacities using Row Level Security may experience issues while adding non-mail-enabled security groups to roles with the message, "The Role could not be updated. Please try again later". As a workaround, users can move their workspace to Shared, add the security group, then move it back to the capacity. Engineers have identified the root cause and a fix is expected to be deployed by end-of-day 01/16/2021.


Above issue is still not fixed .

Status: New
Regular Visitor

We have URGENT deployments, Please provide some estimated timeframe of resolution as 1/16 has already passed.

Advocate I

We really need new information on these. We've been patiently waiting for this to be fix since 8th January when we discover this issues. Deployment has been held back due to this issue. Please provide a new estimation date so this can be passed on. 

New Member

The support site still has an estimation date of 1/16. We are awaiting deployment and need to have updated dates.

New Member

I still have this issue as well, hope they see our message and update us on when this will be fixed. My boss wouldn't be so patient....

Community Support


I have chech the power bi deployments, it will be deployed before 1/20.

it is currently being deployed, some clusters are completed, some of them are delayed, and deployment should be complete within the next few days.


and i also chech some similar icm, the engineer asked the customer to hold off for a few days.


Please wait a few days and test it again




New Member

Agreed this is still an issue.  Can we have an accurate resolution date please?

Regular Visitor

Tried to add row level security as of 1/19/21 8:50am.  Still doesn't work.


How do you move the data model back to capacity?




Regular Visitor

Issue is no longer being posted on support front page. However, I still experience the same issue as described by OP.

Regular Visitor

Still experiencing issues adding users to row level security.  It hangs after clicking Save. 

Here is the error message:



Regular Visitor

 Experciencing the same issue as mentioned above. It has been more than a week. 


Unable to add users in the RLS.