cancel
Showing results for 
Search instead for 
Did you mean: 

500 error when publishing report to preview v2 workspace and other errors

1) When republishing an existing report to our v2 workspace we get a 500 error and are unable to publish. deleting the report and associated dataset from the workspace unblocked us and we were able to publish.

 

2) Now that we've published an app from the workspace, we are unable to publish new reports to the workspace. Unpublishing the app and then republishing the app is not an option as the app is already distributed to 100 people.

 

3) when going to the schedule refresh page of a dataset someone else published, in the preview workspace, the "Take Over" button give an error as well.

Status: Accepted
Comments
Regular Visitor

Same problem here. It is not possible to publish any existing or new reports to a (new experience) workspace when there is an APP already published...

I believe that it was running OK few hours ago.

Community Support

Hi @alexdupler,

 

1. I'm not able to reproduce the issue. Please test again. If issue persists, would you please share the screenshot with error message, please also share information after you click Show Details. 

 

2. Same as issue 1 on my side. I'm not able to reproduce the issue. Please test again. If issue persists, would you please share the screenshot with error message, please also share information after you click Show Details. 

 

3. Based on my test, when we go to dataset settings in preview work space, it will have the error "Failed to load data sources." throws out, After close this dialog and click Take Over, then "Failed to take over dataset." error Status 401 pops out. Is it the issue that you would like to report? Please share the screenshot of whole error message. 

 

@janatap I'm not able to reproduce the issue on my side. Please try again. If issue persists, please share detail information as I suggested above. 

 

Best Regards,
Qiuyun Yu 

Community Support
Status changed to: Needs Info
 
Regular Visitor

@v-qiuyu-msft, here is the error message when clicked to Publish in PBI Desktop and choose new experience workspace with APP already published. Unfortunately there is no Show details option.

 

When I unpublish APP it is without any problems. Also publishing to "old" workspace is without any problems (with or without APP published). 

I tried to do the same home (different computer, different network) and it behaves the same. Also tried to create another new experience workspace to test it and the behaviour is the same.

 

 

Error500.png

Community Support

Hi @alexdupler@janatap,

 

I have reported the publish issue internally: CRI 79921356. will update here once I get any information. 

 

@alexdupler Would you please share more information about "Take Over" issue as I mentioned in my previous post? 

 

Best Regards,
Qiuyun Yu 

Community Support
Status changed to: Accepted
 
Community Support

Hi @alexdupler,

 

As we discussed in Skype, the 3) issue you would like to report is the same as I described in my first post. 

 

I have reported this issue internally: CRI 79923269. Will update here once I get any information. 

 

Best Regards,
Qiuyun Yu 

Regular Visitor

Hi @v-qiuyu-msft,

any news regarding this issue? I would like to deploy few reports on new app workspaces but it still doesn't allow me.. Do I have to use the old workspace?

 

Thanks.

Pavel

Frequent Visitor

I am also getting a 500 error regarding new app workspaces where an app has been published. But I am getting it when opening a BI Desktop file for a report using a BI Service dataset in that app workspace, or when tring to build a new report that attempts to connect to a dataset in that app workspace.

BI Error.JPGOld App Workspace.JPGConnecting to an old app workspace is fine.

New App Workspace.JPGJust trying to open a new app workspace was fine, until the app was posted. Now, you get the 500 error.

Community Support

Hi all, 

 

For the issues about report publish and dataset take over, we expect to start the QFE process to MSIT next week, after that it will take another week to reach production clusters. 

 

Best Regards,

Qiuyun Yu