Reply
Frequent Visitor
Posts: 5
Registered: ‎07-12-2018
Accepted Solution

redshift Connection (Fatal Error: Too many connections for the User)

 

2.pngError messageI was able to sucessfully connect to Redshift DB but, when I select multiple tables at once and tried to import them into the model, I get error as follows:

 

This problem persists if I made changes to several tables and click on "Close & Apply" to go into report view, I see the same error, but it refreshes without hassle if I unload the tables and apply changes for one table at a time. 

 

This is not a fieasable solution as, after developing the report I can't make changes in similar fashion.

 

 

I was trying to find the root cause of the problem. If anyone has already afaced and solved similar problem, that would be helpful.

 

Thanks,

Krish


Accepted Solutions
Moderator
Posts: 8,904
Registered: ‎03-10-2016

Re: redshift Connection (Fatal Error: Too many connections for the User)

@krish003,

Based on my research, amazon redshift has per-user connection limit, please check that if you have hit the limitation, you can review this online article to get more details.

Also please check that if there are any locks or active transaction on the data source side, there is a similar thread for your reference.

Regards,
Lydia

View solution in original post


All Replies
Moderator
Posts: 8,904
Registered: ‎03-10-2016

Re: redshift Connection (Fatal Error: Too many connections for the User)

@krish003,

Based on my research, amazon redshift has per-user connection limit, please check that if you have hit the limitation, you can review this online article to get more details.

Also please check that if there are any locks or active transaction on the data source side, there is a similar thread for your reference.

Regards,
Lydia

Highlighted
Frequent Visitor
Posts: 5
Registered: ‎07-12-2018

Re: redshift Connection (Fatal Error: Too many connections for the User)

[ Edited ]

@v-yuezhe-msft 

 

 Thanks for the prompt response,

 

I was able to find the work around for refreshing the tables without any errors by  Disabling-Parallel-Loading of tables from options.

 

Regards,

Krish