cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ACV Frequent Visitor
Frequent Visitor

impersonation 'Identification' is incorrect

impersonation 'Identification' is incorrect, should be 'Impersonation'; This is the message in the GatewayErrors.log with a datasource configured to use 'SSO via kerberos for directquery queries'

1 ACCEPTED SOLUTION

Accepted Solutions
ACV Frequent Visitor
Frequent Visitor

Re: impersonation 'Identification' is incorrect

look no further, I found the solution:

 

For the delegation settings on the gateway service account,

Check 'Trust this user for delegation to specified services only'

And not 'Use Kerberos only' but 'Use any authentication protocol'

4 REPLIES 4
Moderator v-yuezhe-msft
Moderator

Re: impersonation 'Identification' is incorrect

@ACV,

Do you connect to SQL Server in Power BI Desktop? What is your gateway service account and SQL Server service account? 

Please make sure that you have configured all steps following the guide in "Configuring Kerberos Constrained Delegation for the gateway and data source" section of this article.



Regards,
Lydia

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
ACV Frequent Visitor
Frequent Visitor

Re: impersonation 'Identification' is incorrect

Thank you for your interest in my problem
 
Guy

 

 

 

I installed Network Monitor on the Server where the Gateway is and I receive the 2 messages in my Traffic:
 
KerberosV5: As Request Cname: u99gdc@acv-csc.be Realm: ACV-CSC.ACV-CSC-PRIV.be  Sname: krbtgt\ACV-CSC.ACV-CSC-PRIV.BE
KerberosV5: KRB_Error - KDC_ERR_PREAUTH_REQUIRED (25)

 

Moderator v-yuezhe-msft
Moderator

Re: impersonation 'Identification' is incorrect

@ACV,

As per this blog KDC_ERR_PREAUTH_REQUIRED does not indicate there is a problem at all. Do you use SQL Server data source? Have you configured all the required settings?

Regards,
Lydia

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
ACV Frequent Visitor
Frequent Visitor

Re: impersonation 'Identification' is incorrect

look no further, I found the solution:

 

For the delegation settings on the gateway service account,

Check 'Trust this user for delegation to specified services only'

And not 'Use Kerberos only' but 'Use any authentication protocol'