cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
renzhaj Frequent Visitor
Frequent Visitor

fail to install on-premise data gateway

Hi All,

I have installed on-premise data gateway in my laptop and it's working geate. Then, I am trying to install it on one of my windows server. I got the following error in the log file.  I guess it's sort of related to authorization. anyone has idea? Thanks

 

 

Calling custom action Microsoft.DataTransfer.EgwInstallUtils!Microsoft.PowerBI.EgwInstallUtils.CustomActions.StartServiceToCreateUser

Exception thrown by custom action:

System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.ServiceProcess.TimeoutException: Time out has expired and the operation has not been completed.

   at System.ServiceProcess.ServiceController.WaitForStatus(ServiceControllerStatus desiredStatus, TimeSpan timeout)

   at Microsoft.PowerBI.EgwInstallUtils.CustomActions.RestartServiceImpl(String serviceDisplayName, TimeSpan timeout)

   at Microsoft.PowerBI.EgwInstallUtils.CustomActions.StartServiceToCreateUser(Session session)

   --- End of inner exception stack trace ---

   at System.RuntimeMethodHandle.InvokeMethod(Object target, Object arguments, Signature sig, Boolean constructor)

   at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object parameters, Object arguments)

   at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object parameters, CultureInfo culture)

   at Microsoft.Deployment.WindowsInstaller.CustomActionProxy.InvokeCustomAction(Int32 sessionHandle, String entryPoint, IntPtr remotingDelegatePtr)

CustomAction StartServiceToCreateUser returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)

Action ended 16:08:39: StartServiceToCreateUser. Return value 3.

Action ended 16:08:39: INSTALL. Return value 3.

3 REPLIES 3
Super User
Super User

Re: fail to install on-premise data gateway

@renzhaj Server installs usually force you to deal with the IT infrastructure whereas your machine is pretty easy. Have you followed the install guide? https://powerbi.microsoft.com/en-us/documentation/powerbi-gateway-onprem/

Also the troubleshooting and in-depth articles solve the vast majority of issues you'll encounter.

 

https://powerbi.microsoft.com/en-us/documentation/powerbi-gateway-onprem-tshoot/

https://powerbi.microsoft.com/en-us/documentation/powerbi-gateway-onprem-indepth/

Near SE WI? Join our PUG MSBIWI
renzhaj Frequent Visitor
Frequent Visitor

Re: fail to install on-premise data gateway

 @Seth_C_Bauer   Thank you for the reply. I have reviewed the guide and posts but still can't solve it.

 

I noticed a related applciation error in Server Event Viewer. 

It's .NET Runtime error. I confirmed 4.5 version had been installed but it seem 4.0 version is being used.   Any ideas?

 

Application: GatewayInstall.exe
Framework Version: v4.0.30319
Description: The application requested process termination through System.Environment.FailFast(string message).
Message: Unrecoverable system error.
Stack:
at System.Environment.FailFast(System.String)
at MS.Internal.Invariant.FailFast(System.String, System.String)
at System.IO.Packaging.Package.AddIfNoPrefixCollisionDetected(ValidatedPartUri, System.IO.Packaging.PackagePart)
at System.IO.Packaging.Package.GetPartHelper(System.Uri)
at System.IO.Packaging.Package.GetPart(System.Uri)
at System.IO.Packaging.PackWebResponse+CachedResponse.GetResponseStream()
at System.IO.Packaging.PackWebResponse.GetResponseStream()
at System.IO.Packaging.PackWebResponse.get_ContentType()
at System.Windows.Media.Imaging.BitmapDecoder.SetupDecoderFromUriOrStream(System.Uri, System.IO.Stream, System.Windows.Media.Imaging.BitmapCacheOption, System.Guid ByRef, Boolean ByRef, System.IO.Stream ByRef, System.IO.UnmanagedMemoryStream ByRef, Microsoft.Win32.SafeHandles.SafeFileHandle ByRef)
at System.Windows.Media.Imaging.BitmapDecoder.CreateFromUriOrStream(System.Uri, System.Uri, System.IO.Stream, System.Windows.Media.Imaging.BitmapCreateOptions, System.Windows.Media.Imaging.BitmapCacheOption, System.Net.Cache.RequestCachePolicy, Boolean)
at System.Windows.Media.Imaging.BitmapImage.FinalizeCreation()
at System.Windows.Media.Imaging.BitmapImage.EndInit()
at System.Windows.Media.Imaging.BitmapImage..ctor(System.Uri, System.Net.Cache.RequestCachePolicy)
at Microsoft.DataProxy.EgwInstallBA.PrecheckViewModel..ctor(Microsoft.DataProxy.EgwInstallBA.MainViewModel, Microsoft.DataProxy.EgwInstallBA.WizardViewModelBase)
at Microsoft.DataProxy.EgwInstallBA.MainViewModel.DetectComplete(System.Object, Microsoft.Tools.WindowsInstallerXml.Bootstrapper.DetectCompleteEventArgs)
at Microsoft.Tools.WindowsInstallerXml.Bootstrapper.BootstrapperApplication.OnDetectComplete(Microsoft.Tools.WindowsInstallerXml.Bootstrapper.DetectCompleteEventArgs)
at Microsoft.Tools.WindowsInstallerXml.Bootstrapper.BootstrapperApplication.Microsoft.Tools.WindowsInstallerXml.Bootstrapper.IBootstrapperApplication.OnDetectComplete(Int32)

jcbowyer Frequent Visitor
Frequent Visitor

Re: fail to install on-premise data gateway

Hello, we are having an identical error message.  Our machines are heavily configure by IT for security.  I believe this error is probably related to a security configuration but I am not clear the exact configuration that we need to request to change to allow authorization.