Reply
Regular Visitor
Posts: 20
Registered: ‎11-15-2016
Accepted Solution

Scheduled refresh for excel file with on-premise gateway

[ Edited ]

I installed the on premise data gateway and managed to get the connection running.

When I enter "manage gateways"  on app.power.com it tells me   "Online: You are good to go".

I also added data sources, (local excel files) which are on the same server where the gateway is installed and it tells me "Connection successful".

 

When I go to my dataset and click scheduled refresh it tells me:

"Your data gateway (PowerBI - personal) is offline. To refresh scheduling, make sure your gateway is online."

 

Why should I need a personal gateway if my on-premise gateway is already succesfully connected to the data?


Accepted Solutions
Moderator
Posts: 9,918
Registered: ‎03-10-2016

Re: Scheduled refresh for excel file with on-premise gateway

[ Edited ]

Hi @phyten,

You are using different paths to connect to Excel in Power BI Service and Power BI Desktop.

You connect to the Excel file using \\servername\issueexport\jiraexport_its.xlsx path in Power BI Desktop, you would need to use same path when adding Excel data source under gateway. There is an example for your reference.
2.PNG1.PNG

In addition, click option menu in the following screenshot, there is a option called"Not a solution", click it to undo the mark operation.
4.PNG

Thanks,
Lydia Zhang

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post


All Replies
Moderator
Posts: 9,918
Registered: ‎03-10-2016

Re: Scheduled refresh for excel file with on-premise gateway

Hi @phyten,

Does your dataset only contain Excel data source?  If that is the case, firstly, right click your Excel file and select “Properties”, check the location of the Excel file, add excel name in the location and use the location as full path.
1.PNG


Secondly, check your user account in the Settings of your computer,  enter this user account(domain\user in my scenario) as Windows username when adding Excel data source under gateway, and enter relevant password. This way, you should have no issues setting schedule refresh for your dataset using on-premises gateway.
2.PNG3.PNG


However, if you combine Excel data source and other data sources in your dataset, you will also need to add other data sources under on-premises gateway. Otherwise, you will be prompted to use personal gateway.

 

 

Thanks,
Lydia Zhang

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Regular Visitor
Posts: 20
Registered: ‎11-15-2016

Re: Scheduled refresh for excel file with on-premise gateway

[ Edited ]

Thank you for your answer @v-yuezhe-msft. This is pretty much what I did. 

In my published report I had two excel files and one folder but I also added all three sources to the data gateway.

 

Now I made a fresh report with only one excel file called "JiraExport_ITS.xlsx" and published it to the app. I still get the same "error" though.

I also made sure that the "Data Source Name" in "manage gateway" is the same as the "dataset" name in the app. (I am not sure if this is neccessary or powerbi automatically should detect the connection due to the filename"

gateway_online.jpgPicture of "manage gateway"blub.jpgNaming of the datasetdatasetgateway.jpgPicture of "scheduled refresh" for said data.

Moderator
Posts: 9,918
Registered: ‎03-10-2016

Re: Scheduled refresh for excel file with on-premise gateway

Hi @phyten,

Could you please post the screenshot of the data source setting in Power BI Desktop file? My data source in Power BI Desktop is as follows.

1.png

Thanks,
Lydia Zhang

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Regular Visitor
Posts: 20
Registered: ‎11-15-2016

Re: Scheduled refresh for excel file with on-premise gateway

[ Edited ]

Hello @v-yuezhe-msft. Sorry for the late response. I was on vacation.

2017-01-10 09_52_05-.jpg

 

The sourcefile is located on a server. The gateway is installed on the server. I am publishing the pbix file on a different machine though. Could this be the mistake?

If this is the problem. Do you have an idea how I could fix this?

Regular Visitor
Posts: 20
Registered: ‎11-15-2016

Re: Scheduled refresh for excel file with on-premise gateway

By mistake I marked one of the posts as an accepted solution. Is there a way to undo this?

Moderator
Posts: 9,918
Registered: ‎03-10-2016

Re: Scheduled refresh for excel file with on-premise gateway

[ Edited ]

Hi @phyten,

You are using different paths to connect to Excel in Power BI Service and Power BI Desktop.

You connect to the Excel file using \\servername\issueexport\jiraexport_its.xlsx path in Power BI Desktop, you would need to use same path when adding Excel data source under gateway. There is an example for your reference.
2.PNG1.PNG

In addition, click option menu in the following screenshot, there is a option called"Not a solution", click it to undo the mark operation.
4.PNG

Thanks,
Lydia Zhang

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.