cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
gerbrandspaans Frequent Visitor
Frequent Visitor

Salesforce Report Connector not working for double datatypes

We are trying to import a Salesforce report into PowerBI using the built in PowerBI connector. We chose the report we want to ingest, click go and get an error. We checked the data type for the retreived column that reported the error at it is reported as "double", but the error indicates that it is trying to store the data as an integer.

 

We have no way of editing the column datatype in PowerBI so we are stuck and cannot load the information in PowerBI. Please let us know how to proceed.

 

The Saleforce Report (Dutch Locale)

The Salesforce Report

PowerBI Error:

PowerBI Error

 

Salesforce API description of the data in the report:

...
"reportExtendedMetadata" : 
{ 
	"aggregateColumnInfo" : 
	{ 
		"a!DURATION" : 
		{ 
			"dataType" : "double", 
			"label" : "Average Duration" 
		}, 
		"RowCount" : 
		{ 
			"dataType" : "int", 
			"label" : "Record Count" 
		} 
},...

 

5 REPLIES 5
Moderator v-yuezhe-msft
Moderator

Re: Salesforce Report Connector not working for double datatypes

@gerbrandspaans,

What is the region setting in your computer?
1.PNG

Please open advanced Editor of your query in Power BI Desktop query editor, add a step in the source code. if you get any errors, please share the source code here.

#"Changed Type1" = Table.TransformColumnTypes(Source,{{"Avg DURATION", type number}})

2.PNG

Regards,
Lydia

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
gerbrandspaans Frequent Visitor
Frequent Visitor

Re: Salesforce Report Connector not working for double datatypes

Hi Lydia,

Hi @v-yuezhe-msft thanks for the help.

My region settings were set to display settings default, and I've set it to match the English (US) setting.

 

Below is my source code. I'm using the connector, and it seems to get the report list from SF, and then the report, then immediatly throws an error. This means that adding the line you suggest does not help.

 

let
    Source = Salesforce.Reports("https://test.salesforce.com"),
    #"00O1l000000FFx8EAG" = Source{[Name="00O1l000000FFx8EAG"]}[Data],
    #"Changed Type1" = Table.TransformColumnTypes(Source,{{"Avg DURATION", type number}})
in
    #"Changed Type1"

This still gives me new error that the column is not found, most likely due to the workings of the connector.

 

Also tried to match the column name to that of the label in the API response. No dice, though.

 

Kind regards,

Moderator v-yuezhe-msft
Moderator

Re: Salesforce Report Connector not working for double datatypes

@gerbrandspaans,

How about you change region setting of your computer to Dutch? Please also update your Power Query code to the following:

let
    Source = Salesforce.Reports("https://test.salesforce.com"),
    #"00O1l000000FFx8EAG" = Source{[Name="00O1l000000FFx8EAG"]}[Data],
    #"Changed Type1" = Table.TransformColumnTypes(#"00O1l000000FFx8EAG",{{"Avg DURATION", type number}})
in
    #"Changed Type1"



Regards,
Lydia

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
gerbrandspaans Frequent Visitor
Frequent Visitor

Re: Salesforce Report Connector not working for double datatypes

 

Capture.PNG

I've worked out the name for the column ("Duration"), but neither the options you have given (locale settings) nor even removing the column works. Still not working.

Edit: I've also restarted the computer to make sure the changes were made into effect, and restarted PowerBI. This still does not work, neither for US or Dutch locales.

 

Highlighted
Moderator v-yuezhe-msft
Moderator

Re: Salesforce Report Connector not working for double datatypes

@gerbrandspaans

Please open a ticket in Power BI Support site.
Support Ticket.gif

Regards,
Lydia

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.