Reply
Frequent Visitor
Posts: 20
Registered: ‎07-28-2017
Accepted Solution

Power BI Gateway Installation

Hi all.  

 

I'm trying to install the Power BI Data Gateway on a computer which happens to be running Windows Server Standard 2007 but without any success. I have installed the personal version on my laptop but need a "always on" computer for the dashboards and reports to work.  

 

However, when installing it, it keeps failing with the error of:  

 

MSI (s) (6C:FC) [12:12:59:250]: Created Custom Action Server with PID 4956 (0x135C). MSI (s) (6C:E4) [12:12:59:374]: Running as a service.

MSI (s) (6C:E4) [12:12:59:374]: Hello, I'm your 32bit Elevated custom action server.

MSI (s) (6C:68) [12:13:00:500]: Executing op: ActionStart(Name=InstallServices,Description=Installing new services,Template=Service: [2])

MSI (s) (6C:68) [12:13:00:515]: Executing op: ProgressTotal(Total=1,Type=1,ByteEquivalent=1300000)

MSI (s) (6C:68) [12:13:00:515]: Executing op: ServiceInstall(Name=PBIEgwService,DisplayName=On-premises data gateway service,ImagePath="C:\Program Files\On-premises data gateway\Microsoft.PowerBI.EnterpriseGateway.exe",ServiceType=16,StartType=2,ErrorControl=32769,,,,StartName=NT SERVICE\PBIEgwService,Password=**********,Description=The on-premises data gateway service)

MSI (s) (6C:68) [12:13:01:843]: Product: EgwComponents -- Error 1923. Service 'On-premises data gateway service' (PBIEgwService) could not be installed. Verify that you have sufficient privileges to install system services. Error 1923. Service 'On-premises data gateway service' (PBIEgwService) could not be installed. Verify that you have sufficient privileges to install system services.

MSI (s) (6C:68) [12:13:01:843]: User policy value 'DisableRollback' is 0

MSI (s) (6C:68) [12:13:01:843]: Machine policy value 'DisableRollback' is 0 Action ended 12:13:01: InstallFinalize. Return value 3.  

 

So if I understand the message correctly, it is telling me that it cannot a service could not be installed due to insufficient privileges on the computer, however, my user is within the administrators group.  

 

Having read several fixes for this problem on here, none work in my particular instance. I cannot alter anything within the local policies, user rights assignments and then log on as a service since everything ia greyed out with the text underneath complaining the service not being compatiable with Windows 2000 service pack 1 and it update to something much later!  

 

Any help would be gratefully received.  Thanks  


Accepted Solutions
Moderator
Posts: 9,894
Registered: ‎03-10-2016

Re: Power BI Gateway Installation

@jigr69,

Firstly, according to the above error message, you are installing on-premises gateway but not on-premises gateway(personal mode). As per this article, on-premises gateway can only be installed on 64-bit version of Windows 7/Windows Server 2008 R2(or later), please ensure that your server meets this requirement.

Secondly, when installing the on-premises gateway, please ensure that you right-click  the setup package and select “Run as administrator” to start the installation. Also turn off any antivirus software in case that it blocks the installation of Power BI gateway.

Regards,
Lydia

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post


All Replies
Highlighted
Frequent Visitor
Posts: 20
Registered: ‎07-28-2017

Re: Power BI Gateway Installation

I think the issue is down to this:

 

Personal gateway fails to install as a service even though you are a local administrator for the computer - Installation can fail if the user is in the computer’s local Administrator group, but group policy does not allow that username to log on as a service.  At the moment, ensure the group policy allows a user to log on as a service. We’re working on a fix for this issue. 

 

I wonder when Microsoft are going to fix this?

Moderator
Posts: 9,894
Registered: ‎03-10-2016

Re: Power BI Gateway Installation

@jigr69,

Firstly, according to the above error message, you are installing on-premises gateway but not on-premises gateway(personal mode). As per this article, on-premises gateway can only be installed on 64-bit version of Windows 7/Windows Server 2008 R2(or later), please ensure that your server meets this requirement.

Secondly, when installing the on-premises gateway, please ensure that you right-click  the setup package and select “Run as administrator” to start the installation. Also turn off any antivirus software in case that it blocks the installation of Power BI gateway.

Regards,
Lydia

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Frequent Visitor
Posts: 3
Registered: ‎09-21-2017

Re: Power BI Gateway Installation

I am having a similar Problem installing the Gateway on My server. The server is windows server 2012 R2, 64 bit, 8 core, 12 GB RAM, and have .NET 4.5.

 

I run the installer as administrator, and it almost immediately crashes. This is what the error output shows.

 

Problem signature:
Problem Event Name: CLR20r3
Problem Signature 01: PowerBIGatewayInstaller.exe
Problem Signature 02: 14.16.6464.1
Problem Signature 03: 59c0a4e1
Problem Signature 04: PowerBIGatewayInstaller
Problem Signature 05: 14.16.6464.1
Problem Signature 06: 59c0a4e1
Problem Signature 07: 3c
Problem Signature 08: 1d
Problem Signature 09: System.Windows.Markup.XamlParse
OS Version: 6.3.9600.2.0.0.272.7
Locale ID: 1033
Additional Information 1: 9b1d
Additional Information 2: 9b1d8426cbdd84936a2a7b3936a24820
Additional Information 3: 884f
Additional Information 4: 884fd40582a0bf4f8ef4e1b1e50bce6f

Read our privacy statement online:
http://go.microsoft.com/fwlink/?linkid=280262

If the online privacy statement is not available, please read our privacy statement offline:
C:\Windows\system32\en-US\erofflps.txt

LSP Frequent Visitor
Frequent Visitor
Posts: 2
Registered: ‎02-07-2018

Re: Power BI Gateway Installation

Hi,

 

I also have this issue of the "PowerBIGatewayInstaller Stopped Working" immediatly when starting the program.

- tried run as admin

- tried on multiple servers, meeting the requirements ( win2012R2 , .net , ....)

- I am local admin on all the servers

- disabled the local antivrus ( symantec endpoint)

 

 

Error detailed info ...

Problem signature:

Problem Event Name: CLR20r3

Problem Signature 01: PowerBIGatewayInstaller.exe

Problem Signature 02: 14.16.6584.1

Problem Signature 03: 5a5eae17

Problem Signature 04: PowerBIGatewayInstaller

Problem Signature 05: 14.16.6584.1

Problem Signature 06: 5a5eae17

Problem Signature 07: 3c

Problem Signature 08: 1d

Problem Signature 09: System.Windows.Markup.XamlParse

OS Version: 6.3.9600.2.0.0.272.7

Locale ID: 2057

Additional Information 1: 150b

Additional Information 2: 150b7dcd149277ac313df1f28802824e

Additional Information 3: 19cd

Additional Information 4: 19cde1d11521975f5c38056385345d2a

LSP Frequent Visitor
Frequent Visitor
Posts: 2
Registered: ‎02-07-2018

Re: Power BI Gateway Installation

Issue solved after installing the  .NET 4.6 

Visitor
Posts: 1
Registered: ‎02-21-2017

Re: Power BI Gateway Installation

After much frustration and having previously had no problems when installing on-prem gateways.... Installing .NET 4.6 worked for me too.