cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
DavidKress Frequent Visitor
Frequent Visitor

HELP! The MSOLAP.8 provider is not registered on the local machin

I have a PowerQuery which I have successfully imported to PowerBI.  When I click to refresh data I get the error "An error happened while reading data from the provider: 'The MSOLAP.8 provider is not registered on the local machine."  

 

I went into Excel and checked the data connection string being used to connect to the SSAS cube the Power Query is connected to and it's MSOLAP.8

 

I also went into registry and it also shows MSOLAP.8

 

If anybody knows how to fix this is would be GREATLY appreciated!

 

Thanks, dave

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
DavidKress Frequent Visitor
Frequent Visitor

Re: HELP! The MSOLAP.8 provider is not registered on the local machin

Figured out the solution.  Installing the client libraries for connecting to Azure Analysis Services.  I didn't have any 32 vs 64 bit conflicts, and MSOLAP.8 was already in my registry. Dowloading the MSOLAP (amd64) libraries at this link did the trick. 

https://docs.microsoft.com/en-us/sql/analysis-services/instances/data-providers-used-for-analysis-se...

2 REPLIES 2
Super User
Super User

Re: HELP! The MSOLAP.8 provider is not registered on the local machin

Could be a 32-bit vs. 64-bit issue. I have seen this sort of thing when Office is 32-bit and Power BI Desktop is 64-bit, for example. Also, you can check out this: https://dba.stackexchange.com/questions/36001/how-to-fix-the-ole-db-provider-msolap-has-not-been-reg... https://community.powerbi.com/t5/Service/Unable-to-connect-to-OLE-DB/m-p/325973

Did I answer your question? Mark my post as a solution!

Proud to be a Datanaut!


Highlighted
DavidKress Frequent Visitor
Frequent Visitor

Re: HELP! The MSOLAP.8 provider is not registered on the local machin

Figured out the solution.  Installing the client libraries for connecting to Azure Analysis Services.  I didn't have any 32 vs 64 bit conflicts, and MSOLAP.8 was already in my registry. Dowloading the MSOLAP (amd64) libraries at this link did the trick. 

https://docs.microsoft.com/en-us/sql/analysis-services/instances/data-providers-used-for-analysis-se...