cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
mimig Frequent Visitor
Frequent Visitor

Google Trends interest over time graph does not display correctly

When trying to integrate Google Trends with Power BI, I can add a tile to my dashboard, but the tile only displays the top 1/3 of the chart - the rest is just white.

 

I've got a screencap of the problem here: https://1drv.ms/i/s!Aqmkk_6dD5nZi4FjsMkuVmrl8-t6AA.

 

Any ideas?

 

 

 

7 REPLIES 7
Moderator v-qiuyu-msft
Moderator

Re: Google Trends interest over time graph does not display correctly

Hi @mimig,

 

I notice there is a warning signal in the chart, please click it to see the detail message.

 

q2.PNG

 

I guess there should be large amount of data which can't display in the chart, please try to filter data to display less data see if the chart can display completely.

 

Best Regards,
Qiuyun Yu

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
mimig Frequent Visitor
Frequent Visitor

Re: Google Trends interest over time graph does not display correctly

The warning signal says "This widget contains web content not provided by Microsoft. Web content could contain code with security or privacy risks".

 

The actual code I'm trying to embed is as follows, it's just a generic google trend chart:

 

<script type="text/javascript" src="https://ssl.gstatic.com/trends_nrtr/884_RC03/embed_loader.js"></script>
<script type="text/javascript">
trends.embed.renderExploreWidget("TIMESERIES", {"comparisonItem":[{"keyword":"\"Azure DocumentDB\"","geo":"","time":"today 1-m"}],"category":0,"property":""}, {"exploreQuery":"date=today%201-m&q=%22Azure%20DocumentDB%22"});
</script>

 

I got this by going to https://www.google.com/trends/explore?q=%22Azure%20DocumentDB%22, clicking the ... in the line chart and clicking Embed. I then go to PowerBI, click Add tile->Web content and then paste the code into the Embed Code box.

mimig Frequent Visitor
Frequent Visitor

Re: Google Trends interest over time graph does not display correctly

Someone suggested I try this in different browsers, and it turns out that the Google Trend tile renders fine in Google Chrome. In Edge, only the top portion renders (as shown in my screencap) and in IE none of the tile renders- it's totally empty.

Moderator v-qiuyu-msft
Moderator

Re: Google Trends interest over time graph does not display correctly

Hi @mimig,

 

I can reproduce the issue on both Edge and IE, and already reported this issue. Will update here once get the feedback.

 

Best Regards,

Qiuyun Yu

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Re: Google Trends interest over time graph does not display correctly

@mimig: It would be interesting if you could share with us how you retrveived data from Google Trends ?

Highlighted
mimig Frequent Visitor
Frequent Visitor

Re: Google Trends interest over time graph does not display correctly

From a PowerBI.com dashboard, click Add Tile, Web Content, Next. Then paste in the embedded code from trends.google.com.

 

To get the embedded code, go to trends.google.com, enter your search terms and get the line graph. Then click the arrow in the upper right of the graph, and click Embed. Copy the code from that new window into PowerBI.com.

 

I just retried this though, and I still only get the top 1/3 of the graph to display.

Re: Google Trends interest over time graph does not display correctly

@mimig: Thanks for sharing. Just so you know, this works fine when I tried this. Using Chrome and loggen in on my personal account with google.