cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
omdavies Occasional Visitor
Occasional Visitor

Dynamics CRM API v8 compatibility

It appears that from the June 2018 release there is a compatibility issue between PowerBI and  v8.x of the Dynamics CRM API.  Attempting to create a new connection results in:

 

'OData: The Feed's metadata document appears to be invalid'

 

We have been advised that using v9.x of the API fixes this issue but this is not possible in the organisation we are working  in.  This is a massive issue and a blocker to update of the product, please could you advise what we should be doing ?  Only option we seem to have is to revert to the May 2018 release.

1 ACCEPTED SOLUTION

Accepted Solutions
Moderator v-yuezhe-msft
Moderator

Re: Dynamics CRM API v8 compatibility

@omdavies,

I have reported this issue internally: CRI 72081044. Please use the workaround below.

Create a blank query in Power BI Desktop, copy the following code into Advanced Editor of this blank query.

let
    Source = OData.Feed("https://<tenant>.api.crm.dynamics.com/api/data/v8.2/")
in
    Source



Regards,
Lydia

 

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
3 REPLIES 3
Moderator v-yuezhe-msft
Moderator

Re: Dynamics CRM API v8 compatibility

@omdavies,

I have reported this issue internally: CRI 72081044. Please use the workaround below.

Create a blank query in Power BI Desktop, copy the following code into Advanced Editor of this blank query.

let
    Source = OData.Feed("https://<tenant>.api.crm.dynamics.com/api/data/v8.2/")
in
    Source



Regards,
Lydia

 

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
crmwizard New Member
New Member

Re: Dynamics CRM API v8 compatibility

I've encountered this issue as well, and have a few observations.  First, the issue does not occur in older versions of Power BI Desktop but does occur in the latest.  Second, this seems to happen only when connecting to the v8.2 endpoint on an actual v8.2 Dynamics org - using the 8.2 endpoint on a v9.0 org does not have the issue.  Third, the error being returned suggests that the OData connector (and also the Dynamics connector) are trying to connect via OData v7.0, while the v4.0 Dynamics endpoint is returning values removed in OData v7.  Fourth, I discovered that if the connection showed up in the Recent Sources button, I can connect to it there with no issue, but if I try to create it as a new connection it will not load.  So the issue only presents itself when creating a new connection by entering the URL but NOT from the Recent Sources.

 

I hope this helps pinpoint the issue for a speedy resolution!

Anonymous
Not applicable

Re: Dynamics CRM API v8 compatibility

Hi Lydia,

 

Has there been any update on this issue CRI 72081044? v9.1 doesn't work but v8.2 like you mentioned below does

 

Many thanks