cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
lovergine Frequent Visitor
Frequent Visitor

lab 1 - q3

Dear all,

I have tried many times the steps of the lab 1 - exercise 3 and the results is:


How many rows were imported from the Country Population query? 5


How many distinct values of the Year column were imported from the Country Population query? 1

... but I got the wrong result ...

Wuold you mind to explain me my mistakes? ... and why?


Best regards

sl

1 ACCEPTED SOLUTION

Accepted Solutions
nillock Frequent Visitor
Frequent Visitor

Re: lab 1 - q3

Hello sir.

it is possible that you forgot to "un-piviot" the Country and Population data &colonSmiley Wink.

since the origional file has only 5 rows but spread out over 17 columns

(looking somthing like this on initial import)

Population initial import.jpg

it sounds like you were able to remove the first 4 rows and promote the headders just fine.

but perhaps forgot to run the unpiviot function. below are the steps:

 

  1. Select the "Country" column
  2. go to the "Transform" tab in the ribbon
  3. select the dropdown chevron beside the "unpiviot" option.
  4. choose to unpiviot OTHER columns

should look like this:

Population unPiviot step.jpg

you should endup with a very narrow and long table with the countries repeated with the years and values as row entries like this:

Population final state.jpg

 

Hope this helps.

let me know if you need more.

Cheers.

Ct

8 REPLIES 8
nillock Frequent Visitor
Frequent Visitor

Re: lab 1 - q3

Hello sir.

it is possible that you forgot to "un-piviot" the Country and Population data &colonSmiley Wink.

since the origional file has only 5 rows but spread out over 17 columns

(looking somthing like this on initial import)

Population initial import.jpg

it sounds like you were able to remove the first 4 rows and promote the headders just fine.

but perhaps forgot to run the unpiviot function. below are the steps:

 

  1. Select the "Country" column
  2. go to the "Transform" tab in the ribbon
  3. select the dropdown chevron beside the "unpiviot" option.
  4. choose to unpiviot OTHER columns

should look like this:

Population unPiviot step.jpg

you should endup with a very narrow and long table with the countries repeated with the years and values as row entries like this:

Population final state.jpg

 

Hope this helps.

let me know if you need more.

Cheers.

Ct

lovergine Frequent Visitor
Frequent Visitor

Re: lab 1 - q3

Dear Nillock

thank you so much!

you are very kind...

 

best regards

saverio

 

 

sureshkumar_BI Frequent Visitor
Frequent Visitor

Re: lab 1 - q3

Hello,

 

I have followed every step, which including  "Unpivot Other Columnsand "Filter out the year 1999". 

Lab1Q3.jpg

5 rows were imported, but asnwer shows as wrong, please assist me where went wrong.

 

Thanks.

Re: lab 1 - q3

Filter out the year 1999,it means that you need to remove the data about 1999 or before, so you should only see data after year 2000.

sureshkumar_BI Frequent Visitor
Frequent Visitor

Re: lab 1 - q3

Thank you for the clarification, i have corrected it and got expected results.

srikanth1 Visitor
Visitor

Re: lab 1 - q3


@nillock wrote:

Hello sir.

it is possible that you forgot to "un-piviot" the Country and Population data &colonSmiley Wink.

since the origional file has only 5 rows but spread out over 17 columns

(looking somthing like this on initial import)

Population initial import.jpg

it sounds like you were able to remove the first 4 rows and promote the headders just fine.

but perhaps forgot to run the unpiviot function. below are the steps:

 

  1. Select the "Country" column
  2. go to the "Transform" tab in the ribbon
  3. select the dropdown chevron beside the "unpiviot" option.
  4. choose to unpiviot OTHER columns

should look like this:

Population unPiviot step.jpg

you should endup with a very narrow and long table with the countries repeated with the years and values as row entries like this:

Population final state.jpg

 

Hope this helps.

let me know if you need more.

Cheers.

Ct


 But the question asks us to filter the year 1999 and then load into the power BI right ,so if we filter for the year 1999 we get only 5 rows and one distinct year. I am confused here.

ankalita Frequent Visitor
Frequent Visitor

Re: lab 1 - q3

Dear All,

  Filter out 1999 means that you should see data Year 2000 onwards. Apply date filter. It will show exact count.

 To see distinct count duplicate the Year coulmn and look for  Distinct count values under Statistics tab.

 Thanks

 hope, it help

 

ankalita Frequent Visitor
Frequent Visitor

lab 1 - Q3

Dear All,

  For this query, Filter out 1999 means that you should see data Year 2000 onwards. Apply date filter. It will show exact count.

 To see distinct count duplicate the Year coulmn and look for  Distinct count values under Statistics tab.

 Thanks

 hope, it help