cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Rajuk06 Frequent Visitor
Frequent Visitor

Problem in Lab 4 Exercise 3 - Can't configure On-premises data gateway

So far, the report you uploaded is rather static. That means, if the data in the Access database changes, the report and dashboard are not updated. You can install Power BI Personal Gateway and schedule data refresh for on-premises data sources, such as the Access database, to keep your report and dashboard on Power BI service up-to-date.

NOTE: Power BI Pro is required to setup scheduled refresh for on-premises data. If you do not have Power BI Pro subscription you can enroll for a free 60 day trial.

  1. On the Power BI website, click My Workspace, click Datasets, click Lab 4 – Starting, and click the Schedule refresh icon.
  2. Power BI Pro is required to setup scheduled refresh for on-premises data. If you do not have Power BI Pro subscription you can enrol for a 60 day trial.
  3. Ensure that you are in the Datasets tab and that the Lab 4 - Starting dataset is selected.
  4. Click Gateway connection and click Install now to download the Power BI Personal Gateway.
  5. When the download is complete, click the On-premises data gateway (by default it installs in personal mode), though I have installed from website {still below steps do not work) to begin installation.
  6. Click Next, accept the license terms, and click Install.
  7. Sign in using your Power BI account and click Close.
  8. In New on-premises data gateway name, type Van Arsdel Sales.
  9. In Recovery key and Confirm recovery key, type Pa$$w0rd, and click Configure.
  10. Click Close.
  11. Expand Data source credentials and, for Country Population by Year.xlsx, click Edit credentials.
  12. For Privacy level setting for this data source, select Organizational, and click Sign in.
  13. Edit credentials for the Data sources that needs updating.
  14. Now you can schedule your data source refresh.

Please help I am struggling since two days and cannot refresh using gateway. I have tried all trobleshouting and I think something wrong in this excercise steps.

1 REPLY 1
azcagaca New Member
New Member

Re: Problem in Lab 4 Exercise 3 - Can't configure On-premises data gateway

I was stuck at the same spot for the same reason. I skipped some steps and picked up with Step 12. In the Gateway Connection section, I turned on Personal Gateway (didn't have a chance to rename it because of the skipped steps. Below that in the Data source credentials section, I clicked on Edit credentials and that brought up a form where the third box was Privacy level setting for this data source. In that dropdown, I selected Organizational (as in Step 12). I did that for all three data sources. 

 

It appears to have worked and I can move on to scheduling.

 

Helpful resources

Announcements
Ask Amir Anything

Exclusive LIVE Community Event No. 2 – Ask Amir Anything

Next in our Triple A series: Ask Amir Netz questions about the latest updates, features and future.

Ask Amanda Anything Q&A

Ask Amanda Anything Q&A

Learn the answers to some of the questions asked during the Amanda Triple A event.

October 2019 Community Highlights

October 2019 Community Highlights

October was a busy month in the community. Read the recap article to learn about some of the events and content.

New Solution Badges

New Solution Badges

Two waves of brand new solution badges are coming! Read the article for more information on our new community badges.

Users Online
Currently online: 150 members 1,753 guests
Please welcome our newest community members: