Reply
Frequent Visitor
Posts: 12
Registered: ‎07-31-2016
Accepted Solution

Lab 4 Exercise 3 - Can't configure gateway

1. I get the following error when I try to install the BI gateway by clicking on 'Install now'

 

PowerBIGatewayInstaller_exe couldn't be downloaded   - Retry / Cancel / View Downloads

 

2. If I click on 'Learn More' - the download and install does complete.

  However, when I go to 'Schedule Refresh'

     Gateway Connection

     Data Source Credentials

     Schedule Refresh

 

     are all grayed out.

 

Please help!

 

Thanks.

 

-Sudip

 

 

 

 

 

 


Accepted Solutions
Frequent Visitor
Posts: 12
Registered: ‎07-31-2016

Re: Lab 4 Exercise 3 - Can't configure gateway

I executed the following steps to resolve the problem:

 

a. Uninstalled the gateway

b. Reinstalled it in c: \Program Files (X86)\Microsoft Power BI Gateway    (after manually creating that directory)

      It again installed the gateway but the launch to configure it failed.

c. In file explorer I navigated to c: \Program Files (X86)\Microsoft Power BI Gateway\2.0\Configurator

d. From File Explorer: I launched GWConfig.exe and this time it completed as per the video.

e. From the PowerBI web interface I continued per the video to update the Data source credentials for all 3 datasets

         Using Windows authentication worked fine without prompting for more ids / passwords

f. From there on it was as per the video.

View solution in original post


All Replies
Frequent Visitor
Posts: 6
Registered: ‎08-11-2016

Re: Lab 4 Exercise 3 - Can't configure gateway

Hi sschahal , 

 

you can download it from offical website :

 

https://powerbi.microsoft.com/en-us/gateway/

 

i faces like same your issue and solve it by download from this link Smiley Happy

 

enjoy Smiley Happy

Frequent Visitor
Posts: 12
Registered: ‎07-31-2016

Re: Lab 4 Exercise 3 - Can't configure gateway

Hi Abdul,

 

Thanks for the reply.  I tried your approach and it does install the gateway but when it goes to launch the UI to configure it, it just seems to go into a black hole i.e., disappear without a trace.

 

Is there a way to launch the UI to configure the gateway given that it is already installed?

 

Thanks,

 

-Sudip

Frequent Visitor
Posts: 12
Registered: ‎07-31-2016

Re: Lab 4 Exercise 3 - Can't configure gateway

I executed the following steps to resolve the problem:

 

a. Uninstalled the gateway

b. Reinstalled it in c: \Program Files (X86)\Microsoft Power BI Gateway    (after manually creating that directory)

      It again installed the gateway but the launch to configure it failed.

c. In file explorer I navigated to c: \Program Files (X86)\Microsoft Power BI Gateway\2.0\Configurator

d. From File Explorer: I launched GWConfig.exe and this time it completed as per the video.

e. From the PowerBI web interface I continued per the video to update the Data source credentials for all 3 datasets

         Using Windows authentication worked fine without prompting for more ids / passwords

f. From there on it was as per the video.

Highlighted
Frequent Visitor
Posts: 2
Registered: ‎11-14-2016

Re: Lab 4 Exercise 3 - Can't configure gateway

Ditto on the above, but I also should mention that I was at home on a very fast wireless network, and nothing was working. So I went into the office this morning on our company network and everything worked fine, much faster.

 

The initial link that your get in the PowerBI scheduled refresh to download the gateway doesn't work, but click on the Learn More and you will be sent to the gateway download page. I downloaded it and installed it. The installation and configuration using wireless was very very slow, to the point of locking up my computer.  Once on a wired network though, it went fast. I think it isn't the speed of a wireless connection that is the problem, but the gateway has to negotiate more things when using wireless (my thought, I am not an expert or authority on such).

 

Also, if you are using a 64-bit operating system and I am guessing Office 64-bit, the On-Premises Data Gateway folder is installed in Program Files, not the (x86) version.

 

One last point, when configuring the gateway, it will ask for your Windows user name, it wants MyName@yourcompany.com, or whatever your PowerBI service is working under, not just MyName. Hope this helps.