cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
chathi
New Member

Lab 1 after appending I get the following error ......

"[DataFormat.Error] We couldn't parse the input provided as a Date value."

 

So when i check to see the list of countries, I only see Canada. I have done these steps several times and still run into the same error. As a result my answers to the Lab Questions end up being incorrectCapture.PNG

1 ACCEPTED SOLUTION
jfernandez265
New Member

I was having same problem but I found the solution.

 

The problem:

 

The headers records from the international sales query that were inserted in the load process

 

Solution:

  • Load the folder with the Csv per country
  • Edit the International sales query
  • After loading the folder and before converting the data type to date, go to the country column.
  • Filter so that you exclude "Country" from the filter. Deselect it from the drop down. The fields should parse now.
  • Go on with the exercise and convert the date field to Data Type Date.

 

I think that the conversion failed because encountered a non date format in the records. Instead of Power BI ignoring it it just stopped the query there.

 

Let me know if it works for you.

 

View solution in original post

17 REPLIES 17
jfernandez265
New Member

I was having same problem but I found the solution.

 

The problem:

 

The headers records from the international sales query that were inserted in the load process

 

Solution:

  • Load the folder with the Csv per country
  • Edit the International sales query
  • After loading the folder and before converting the data type to date, go to the country column.
  • Filter so that you exclude "Country" from the filter. Deselect it from the drop down. The fields should parse now.
  • Go on with the exercise and convert the date field to Data Type Date.

 

I think that the conversion failed because encountered a non date format in the records. Instead of Power BI ignoring it it just stopped the query there.

 

Let me know if it works for you.

 

View solution in original post

Thank you! I spent all afternoon working on this and couldn't figure it out. I'm only on Lab 1 Exercise 2. This may be a long course for me!

This worked for me as well - thanks!

 

Not an auspicious beginning for Power BI...

tracyndye
Regular Visitor

I had done it so the system would accept it yesterday but with the wrong number of rows.  Went back to try to get the proper number of rows ( and therefore all the data) and am back to square one with the errors.   Neither solution is working for me.  My question besides how to do this is : Is the date column in both the Sales table and the International table supposed to be in date format or in text?  Seems like if that was clear it would be easier. 

SteefJan1970
New Member

Even after all the suggestions. Nothing really seem to work. Very frustating not able to answer the questions in excercise two resulting in failing the lab. Man Sad

SteefJan1970
New Member

Very frustating and doesn't help me get the right answer in excersice two. I have no control over this and think this is an ill prepared lab!!!

fferreira
New Member

The same is happening with me.


First I though it was due my PBI be in portuguese. So I have installed the english version and the error persist.
Even configurating the locate settings it is happening.

 

Can anyone help me with this?

 

Thanks.

Fernando Maximo Ferreira

I was hitting the same error DataFormat.Error on the Date column. I got around it by using the "Remove Errors" function.

Select the International Sales query, select the Date column, the click on Remove Errors (circled below). After doing this, you can apply the filter and continue.

 

Lab1DateError.PNG

 

Thanks,
Sam Lester (MSFT)

This fixed it for me, thanks!

The actual solution to this is below (the instructions in the course are wrong and the previously suggested solution is not good as it may result to missing rows or wrong dates):

 

1. First, I'm not sure, but it seems to the problem is related to the locale settings of the Power BI -cloud. I have registered my user account and installed my Power BI to a Finnish (Finland) locale. 

 

2. You must stick with the original local (in my case Finnish -locale) in Power BI too, DO NOT change your locale even if the course instructions are saying so. 

 

 

3. When loading the data with Get source, use Publish -button once to check that you can succesfully publish the raw data sets to the cloud.

 

4. Go to edit the query after combining the binary files in Lab 1.

 

5. Select the "Date" -column by right clicking it and use the "Change type" > "Using locale" and enter "Date" and "English (United states)" to the boxes (this is the original locale of the data in the column)

 

6. Then apply & close and everything should go smoothly without errors and your data is still completely correct

 

4. Right 

I ran into this problem today as well.  The solution provided by @mniinioja worked for me. 

 

I tried the solution @SamLester suggested, that one did not work.

 

Hopefully the course owners will have a look at this, and figure out what needs to be fixed in the input data set (or see if there's perhaps a PowerBI bug/change that's causing different behavior now). 

 

I'm using the July 2016 32-bit version of Power BI Desktop.  All regional settings are default English US.

I made the changes suggested above to change locale on the date column.  Then I looked at the country column, clicked load more, and I was able to see all of the options.  Then I went back to the date column and tried to filter the dates per the exercise.  Then when I went back to the Country column and clicked load more, I got the same error again!  Even going back to the date column and trying to change the locale again doesn't solve it.

 

To get it to work for the exercise, I had to do the following:

1) Did the import of data from the folder

2) Went directly to the country column first, load more, and unchecked "Country"

3) Went to the date column and added the filter to only look at data after 12/31/1999

 

I've "sent a frown" and pointed back at this thread.

fferreira
New Member

Hello all. I am getting the same error when filtering the date. It is happening only with the CSV file.

 

First I have installed the PBI in portuguese and after tried in english, but the error yet is happening. I already change the locate configurations too.

Due this I can't proceed with the LAB 1.

 

Can anyone help me?

 

Thanks in Advance.

 

jonsan21
Microsoft
Microsoft

My guess is that you are not using EN-US locale. You need to change this in PBI settings before connecting to the data.

How do i do that? Also is it possible for me to get an email notification when there is a reply to my question?

I manged to figure out how to access the locale and it is US English in the query. So that is not the issue.

 

USEnglishLocale.png

Can you please send a frown from Power BI Desktop so that we can look at what's causing this error?

Helpful resources

Announcements
PBI_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Get Ready for Power BI Dev Camp

Microsoft named a Leader in The Forrester Wave

Microsoft received the highest score of any vendor in both the strategy and current offering categories.

Get Ready for Power BI Dev Camp

Power BI Dev Camp - September 30th, 2021

Mark your calendars and join us for our next Power BI Dev Camp!

PowerPlatform 768x460.png

Microsoft Learn

Check out our new Discover Your Career Path blog post series and get all the details.