cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
savanth_kumar
New Member

power bi dataset showing invalid data as "record " for array data get from json data

Hi Team ,

 

Please help our team to fix the issue as we have a json data processed from azure stream analytics . We have created a query in stream analytics to fetch an array information from json data and we push the output result data to powerBI.In power BI the dataset and fields under dataset created perfectly . But the data in the dataset for the array fields showing "record" which is an invalid data . This issue we are tracked only for array data from json. Normal data it works perfect .Attaching the screenshot of json data. Here the time is showing perfect inpower bi at dataset , but remaining all column fields result showing "report" which is not the expected data or result . 
This is our stream analyicsquery 

 

select
A.context.data.eventtime AS Time,
GetArrayElement(A.context.custom.dimensions, 0) AS Task,
GetArrayElement(A.context.custom.dimensions, 1) AS [Item Name],
GetArrayElement(A.context.custom.dimensions, 2) AS [Item Type],
GetArrayElement(A.context.custom.dimensions, 3) AS Status
INTO
[ItemStatusOutput]
FROM [inputgetevent] AS A

 

 

 

 

sajsonresult.png

Thanks
Savanth S

1 REPLY 1
pliang
Microsoft
Microsoft

I am also running into the same issue, when testing the data on Stream Analytics, the data are shown correctly, but once the output goes to PowerBI, they all became "record".  Does anyone have a work around for this?

Helpful resources

Announcements
Power BI December 2021 Update_carousel 768x460.jpg

Check it Out!

Click here to read more about the December 2021 Updates!

Jan 2022 Dev Camp 768x460 copy.png

Power BI Dev Camp- January 27th, 2022

Mark your calendars and join us for our next Power BI Dev Camp!

UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!