cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper I
Helper I

'pbiviz new --template slicer' no longer working for apiVersion 2.6.0

Hi,

 

I noticed that the 'slicer' template does no longer work:

  1. The code in 'visual.ts' is identical to the code from the 'default' template, not the 'slicer' template.
    Something clearly goes wrong here.
    Other files like 'capabilities.json' seem fine.
  2. pbiviz.json still refers to a (non-existing) dependencies.json file
    This is probably carried over from the older API version and can be fixed by replacing:
    "dependencies": "dependencies.json"
    by
    "dependencies": null

Does anyone know a workaround for 1) above?

Can this please be put on a list to be fixed.

 

Thanks,

Martijn

1 REPLY 1
Highlighted
Helper I
Helper I

Looking at the history of

https://github.com/microsoft/PowerBI-visuals-tools/blob/master/templates/visuals/slicer/src/visual.t...

I see that the slicer visual.ts never contained any meaningful code, it is simply the default visual template with the well known 'count' statement.

I am a bit puzzled now, has the 'slicer' template ever worked?

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Community Conference

Microsoft Power Platform Communities

Check out the Winners!

secondImage

Create an end-to-end data and analytics solution

Learn how Power BI works with the latest Azure data and analytics innovations at the digital event with Microsoft CEO Satya Nadella.

Top Kudoed Authors