cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
rkqpbiviz
Regular Visitor

can't connect visual server - running local host and have installed correct certificates

Hello, 

 

First time posting, please forgive me if I've missed a similar thread elsewhere on the forum. I've installed the pbiviz tools, installed the certificates and am running the localhost before trying to open the dev visual on power bi  (please see attached screen grabs) I've followed all the steps to the letter including uninstalling and reinstalling all tools, certificates, etc. etc. What am I doing wrong?? Has anyone any advice?

 

pbiviz_problem1.PNGpbiviz_problem2.PNG

 

I've removed and reinstalled the certificates from the browser and user, restarted the computer about 5 times now, please if you've any idea what's wrong let me know!

 

thank you,

 

Rose

 

1 ACCEPTED SOLUTION
abinashphuel
Advocate I
Advocate I

Ufff I found the solution, have the same problem as yours tries many different ways install and create certificate. 

 

One mistake I was doing earlier was not installing my certificate in proper location and the proper location was Trusted Root Certification Authorities. I always did first option.. uuuh

 

install-ssl-certificate-windows3.png

View solution in original post

25 REPLIES 25
abinashphuel
Advocate I
Advocate I

Ufff I found the solution, have the same problem as yours tries many different ways install and create certificate. 

 

One mistake I was doing earlier was not installing my certificate in proper location and the proper location was Trusted Root Certification Authorities. I always did first option.. uuuh

 

install-ssl-certificate-windows3.png

View solution in original post

Anonymous
Not applicable

I've tried that, but when I get to the end, I get an Error.

 

"The import failed because the store was read-only, the store was full, or the store did not open correctly"

 

What to do from here? 

 

v-viig
Community Champion
Community Champion

Steps of creating and installing of a certificate are covered in the documentation (Create certificate, Install Certificate).

 

Ignat Vilesov,

Software Engineer

 

Microsoft Power BI Custom Visuals

pbicvsupport@microsoft.com

moeenuddin
New Member

Hi, I am on Mac, Ran the server at 8080. But my power bi code is not connected with the server.

 

Please let me know, what i m missing.

v-chuncz-msft
Community Support
Community Support

@rkqpbiviz,

 

I do not have this issue, it's likely your SSL certificates weren't installed correctly.

https://github.com/Microsoft/PowerBI-visuals/blob/master/tools/CertificateAddWindows.md

Community Support Team _ Sam Zha
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Ok, I've uninstalled and reinstalled the certificates several times, I've closed browsers and restarted the computer alot - I was able to get this working on an old windows 7 but not my laptop - windows 10. I've tried to change the port to run the server but still nothing 😞

 

Anyone else any advice other that 'it works for me'?

This doesn't address your problem, but as a last resort, you could

pbiviz package

and import resulting file from /dist folder to PowerBI.

Hi all,

I have the problem using Edge, but with Chrome I can access the local server and test my custom visuals.

is there anything special to do with Edge?

@Willgart,

 

I just did a test using Microsoft Edge on Windows 10. It works so long as the server is listening on port 8080.

Community Support Team _ Sam Zha
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

It might help someone like me. Try another browser if you get the message in one. I was getting the message in Firefox but not in Chrome. Regards, Prakash

Similar issue here. I received the message in Chrome, which was very frustrating. However in Explorer and Edge it works. Odd and annoying.

Hello @petermcnally@moeenuddin,

 

Chrome browser blocks this address https://localhost:8080 because of non-valid certificate.

Please open the following link in separate browser tab:

https://localhost:8080/assets/status

Chrome will show the warning message, click  advanced > proceed to unsafe version.

After that Chrome will work with dev visual correctly.

 

 

 

Nikita Grachev,
Team Leader

Microsoft Power BI Custom Visuals
pbicvsupport@microsoft.com

Nikita Grachev,
Team Leader
Microsoft Power BI Custom Visuals,
pbicvsupport@microsoft.com

Tried several things and it worked last time... this time again, it worked right after doing this..  So install the cert as trusted root and then do this to make Chrome trust localhost.

Happy to hear that issue is resolved.

 

Ignat Vilesov,

Software Engineer

 

Microsoft Power BI Custom Visuals

pbicvsupport@microsoft.com

Hi nikitagrachev,

 

Just a few words to mention that your solution worked in my case.  I had the very same issue as mentioned by fellow members. I had first decided to remove existing certificate and reinsinstall a new one through pbiviz --install-cert

I could then proceed with Certificate installation [windows prompts process...] and managed to create a new one with success.

So far so so good. Then when trying to launch on Google Chrome... Bang same thing... So before trying to recreate SSL certificate indifinitely... I figured this may not be strictly related to a local issue but mainly on Google Chrome side. As some mentioned if it worked on Microsoft Edge browser and not on Google Chrome then there you go...  I know Google Chrome latest versions have also behaved a bit strangely lately... forcing me to reinstall it a couple of times...   Still your option seemed to do the job, thanks for sharing Smiley Wink

 

 

I have the same problem - cannot get it to run in any browser - Chrome, Edge, or IE.

 

https://localhost:8080/assets/status:

 

This site can’t provide a secure connection

localhost sent an invalid response.

 

  • Try running Windows Network Diagnostics.
ERR_SSL_PROTOCOL_ERROR

Hello @g4ege,

 Please try this url:

https://localhost:8080/assets/status instead of https://localhost:8080/assets/status:

If it doesn't help, update your pbiviz tool and install certificate again:

https://github.com/Microsoft/PowerBI-visuals/blob/master/tools/CertificateAddWindows.md

Nikita Grachev,
Team Leader
Microsoft Power BI Custom Visuals,
pbicvsupport@microsoft.com

I have tried https://localhost:8080/assets/status:

This site can’t provide a secure connection

localhost sent an invalid response.
Try running Windows Network Diagnostics.
ERR_SSL_PROTOCOL_ERROR

 

I have tried updating using:

npm install -g powerbi-visuals-tools

 

C:\Users\gensminger\CustomVisual\d3joy>pbiviz update
info Visual api 1.7.0 updated

C:\Users\gensminger\CustomVisual\d3joy>pbiviz start
info Building visual...
done build complete

info Starting server...
info Server listening on port 8080.

 

I have restarted all browsers, I have tried deleting browser history and cookies, and I have rebooted my machine.  

 

Unfortunately still same result.

v-viig
Community Champion
Community Champion

@g4ege Could you please confirm that your firewall doesn't block PBIVIZ server? You might check it by disabling firewall.

 

Ignat Vilesov,

Software Engineer

 

Microsoft Power BI Custom Visuals

pbicvsupport@microsoft.com

g4ege
Regular Visitor

Yes, I have disabled the Windows Firewall - for both public and private profile.  Same result.'

 

I also checked port 8080 with pbiviz start running: '

 

C:\Users\gensminger>netstat -ano | findstr 8080
TCP 0.0.0.0:8080 0.0.0.0:0 LISTENING 1744
TCP [::]:8080 [::]:0 LISTENING 1744

 

And then stopped the pbiviz server and no longer showed 8080 LISTENING.

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

Top Kudoed Authors