cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
FaizRahman Frequent Visitor
Frequent Visitor

The Web.Page function requires Active Scripting to be enabled in Internet Explorer

I have a webquery and Analysis services which I am using to bring in the data. The refresh is working fine when configured using my personal gateway, but when I try to refresh it using the enterprise gateway, I get the below error:

 

 

Underlying error message: The Web.Page function requires Active Scripting to be enabled in Internet Explorer options. See https://go.microsoft.com/fwlink/?LinkId=506565 for details on how to enable Active Scripting.

DM_ErrorDetailNameCode_UnderlyingHResult: -2147467259
Microsoft.Data.Mashup.ValueError.Reason: DataSource.Error

 


I have checked and Active Scripting is enabled on the machine where enterprise gateway is hosted. Can you please help me sort this out.

1 ACCEPTED SOLUTION

Accepted Solutions
FaizRahman Frequent Visitor
Frequent Visitor

Re: The Web.Page function requires Active Scripting to be enabled in Internet Explorer

Thanks, It worked for us as well, though we used a different approach. The issues was Local Group Policy was blocking the service user(pbiegwservice) to use Active Scripting.

* From the Windows Server Start menu, open the Local Group Policy Editor (gpedit.msc).
* Under Local Computer Policy, expand Computer Configuration > Administrative Templates > Windows Components > Internet Explorer > Internet Control Panel > Security Page > Internet Zone.
* Right-click Allow active scripting and click Edit.
* In the Allow active scripting dialog, click Enabled.
* In the Options area, select Enable from the list.

5 REPLIES 5
Marc1979 Frequent Visitor
Frequent Visitor

Re: The Web.Page function requires Active Scripting to be enabled in Internet Explorer

We are eperiencing the same problem.

 

Last refresh failed: Mon Mar 04 2019 10:33:27 GMT+0100 (Central European Standard Time)
Unable to connect to the data source undefined.

 

Underlying error code:-2147467259 Table: ExchangeRate.
Underlying error message:The Web.Page function requires Active Scripting to be enabled in Internet Explorer options. See for details on how to enable Active Scripting.
DM_ErrorDetailNameCode_UnderlyingHResult:-2147467259
Microsoft.Data.Mashup.ValueError.Reason:DataSource.Error
Cluster URI:WABI-NORTH-EUROPE-redirect.analysis.windows.net
Activity ID: 
Request ID: 
Time:2019-03-04 09:33:27Z

 

We added the url and enabled Active Scripting on the server running Enterprise Gateway.

Also upgraded Enterprise Gateway to the latest version.

 

FaizRahman Frequent Visitor
Frequent Visitor

Re: The Web.Page function requires Active Scripting to be enabled in Internet Explorer

Do let me know if you find any solution, I have been struggling with it from couple of days with no results

Marc1979 Frequent Visitor
Frequent Visitor

Re: The Web.Page function requires Active Scripting to be enabled in Internet Explorer

I will give an update if I have any news, could it be related to the fact that setting Active Scripting in internet explorer is related to the user profile? So you should activate it for the account the enterprise gateway uses to run?

Marc1979 Frequent Visitor
Frequent Visitor

Re: The Web.Page function requires Active Scripting to be enabled in Internet Explorer

We contacted support and applied the following steps:

 

1. Enterprise gateway was running using a local service account, we changed this to a domain user (to change the account you need the restore key of the enteprise gateway)

2. Login as the domain user and set active scripting to true

3. Restart internet explorer

4. Restart the enterprise gateway

5. Refresh dataset

 

This worked for us.

FaizRahman Frequent Visitor
Frequent Visitor

Re: The Web.Page function requires Active Scripting to be enabled in Internet Explorer

Thanks, It worked for us as well, though we used a different approach. The issues was Local Group Policy was blocking the service user(pbiegwservice) to use Active Scripting.

* From the Windows Server Start menu, open the Local Group Policy Editor (gpedit.msc).
* Under Local Computer Policy, expand Computer Configuration > Administrative Templates > Windows Components > Internet Explorer > Internet Control Panel > Security Page > Internet Zone.
* Right-click Allow active scripting and click Edit.
* In the Allow active scripting dialog, click Enabled.
* In the Options area, select Enable from the list.