cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Regular Visitor

Some parameters are greyed out

On PowerBI desktop we open a .pbit file.

On this template we have 4 parameters. Server and database are for connection. (tried with type Any and Text)

gsxJohnny_0-1596466475758.png

 

When we publish it, we click on “Apply later” button.

gsxJohnny_1-1596466475761.png

 

On publishing success, we open it in PowerBI Service. Go to its dataset settings and the parameters used for connection are greyed and values are not equals to values changed before publishing

gsxJohnny_1-1596466685316.png

 

1 ACCEPTED SOLUTION

Accepted Solutions
Regular Visitor

Re: Some parameters are greyed out

Thank you for your response,

 

Yes, I enabled the incremental refresh.

I ask to support and they helps me to fix it.

It was disabled because of type Any, I changed the type into text, and the Apply Later did not take into account changes of the type of the parameters publishing the report. 

View solution in original post

3 REPLIES 3
Highlighted
Super User II
Super User II

Re: Some parameters are greyed out

What's the reason for deferring the application of the changes?  Are you later planning to set the data source to incremental refresh?

Highlighted
Community Support
Community Support

Re: Some parameters are greyed out

Hi @gsxJohnny,

I think you are work with a report who enabled the incremental refresh, right? If this is a case, I think your issue should be related to it. It seems like an incremental refresh dataset will do some pre-processing and loading that not allow you to parameterized and dynamic change the connection string after publishing.

Regards,

Xiaoxin Sheng

Community Support Team _ Xiaoxin
If this post helps, please consider accept as solution to help other members find it more quickly.
Regular Visitor

Re: Some parameters are greyed out

Thank you for your response,

 

Yes, I enabled the incremental refresh.

I ask to support and they helps me to fix it.

It was disabled because of type Any, I changed the type into text, and the Apply Later did not take into account changes of the type of the parameters publishing the report. 

View solution in original post

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Upcoming Events

Experience what’s next for Power BI

See the latest Power BI innovations, updates, and demos from the Microsoft Business Applications Launch Event.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Get Ready for Power BI Dev Camp

Get Ready for Power BI Dev Camp

Mark your calendars and join us for our next Power BI Dev Camp!.