Reply
Regular Visitor
Posts: 33
Registered: ‎09-08-2015
Accepted Solution

Rest API error creating datasets for AzureAS (FailedToDeserializeDatasetError)

I am trying to create a dataset, pointing to an Azure AS model, in Power BI using the REST APIs. I get get the following error:

FailedToDeserializeDatasetError

 

I can successfully create datasets not pointing to an Azure AS model.

 

I use the following post body:

{

"name":"MyTestDataset",
"defaultMode":"AzureAS",
"tables": [],
"datasources":[
{
"name":"dataSource1",
"connectionString":"Data Source=asazure://northeurope.asazure.windows.net/myazureas;Initial Catalog=mydatabase;Cube=Model"
}
]

}

Anyone got this working?


Accepted Solutions
Advisor
Posts: 102
Registered: ‎12-16-2015

Re: Rest API error creating datasets for AzureAS (FailedToDeserializeDatasetError)

The documentation is not correct related to AAS: https://msdn.microsoft.com/en-us/library/mt203562.aspx 

 

It also should be 'defaultMode':'AsOnPrem' for the Azure Analysis Service instead of AzureAS:

{'name':'AAS','defaultMode':'AsOnPrem','tables':[],'datasources':[{'name':'AAS','connectionString':''}]} 

 

-JP

View solution in original post


All Replies
Advisor
Posts: 102
Registered: ‎12-16-2015

Re: Rest API error creating datasets for AzureAS (FailedToDeserializeDatasetError)

The documentation is not correct related to AAS: https://msdn.microsoft.com/en-us/library/mt203562.aspx 

 

It also should be 'defaultMode':'AsOnPrem' for the Azure Analysis Service instead of AzureAS:

{'name':'AAS','defaultMode':'AsOnPrem','tables':[],'datasources':[{'name':'AAS','connectionString':''}]} 

 

-JP

Highlighted
Regular Visitor
Posts: 33
Registered: ‎09-08-2015

Re: Rest API error creating datasets for AzureAS (FailedToDeserializeDatasetError)

Works perfect, thanks!

Frequent Visitor
Posts: 4
Registered: ‎05-07-2018

Re: Rest API error creating datasets for AzureAS (FailedToDeserializeDatasetError)

Problems on creating a new dataset with Power BI's REST API

  

error for me , getting 202 instead of 201 for dataset creation.

 

this is something wrong with the conenction string for postgres.

as it very difficult to understand and findout exactly what needs to be the structure for a postgres datasource.

 

i have tried various patterns for the connection string with no luck.

 

 "datasources":[
      {
         "name":"postgres",
         "connectionString":"Provider=ODBC;Data Source=postgresql://localhost/postgres?user=postgres&password=12345&ssl=prefer;Initial Catalog = postgres; Cube=Model;"
      }
   ]

 

   "datasources":[

      {

         "name":"postgres",

         "connectionString":"Server=localhost;Port=5432;Database=postgres;User Id=postgres;Password=root;"

      }

   ]

}

 

 

datasources":[

      {

         "name":"postgres",

         "connectionString":"Data Source=postgresql://localhost/Postgres?user=other&password=secret;Initial Catalog=Postgres;Cube=Model"

                                OR

                                Data Source=jdbcSmiley Tongueostgresql://localhost/Postgres?user=fred&password=secret&ssl=true

                               

      }

   ]

 

Also, the terms CUBE and INITIAL CATALOG, PROVIDER these keys have very less info available on the net for postgres connection string. A detailed explanation for postgres connection string would be helpful here.