cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

PowerBIEmbedded_AppOwnsData eorr after publishing to IIS

I was able to download the PowerBIEmbedded_AppOwnsData MVC code update the parametes, run it locally and everything worked successfully everytime. However, now I published the solution to our test IIS server and I get the following error:

 

System.ArgumentNullException: Value cannot be null.
Parameter name: authority
   at Microsoft.IdentityModel.Clients.ActiveDirectory.Authenticator.DetectAuthorityType(String authority)
   at Microsoft.IdentityModel.Clients.ActiveDirectory.Authenticator..ctor(String authority, Boolean validateAuthority)
   at PowerBIEmbedded_AppOwnsData.Controllers.HomeController.<EmbedReport>d__9.MoveNext() in C:\Users\[myusername]\Documents\PowerBI-Developer-Samples-master\PowerBI-Developer-Samples-master\App Owns Data\PowerBIEmbedded_AppOwnsData\Controllers\HomeController.cs:line 48

 

Any ideas would be greatly appreciated. I also don't see how it has embedded my original file directory.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Frequent Visitor

I was able to solve this problem. All I had to do was move the cloud.config file over to my site and restart the site (or wait a while) and it was working as expected

View solution in original post

4 REPLIES 4
Highlighted
Frequent Visitor

I was able to solve this problem. All I had to do was move the cloud.config file over to my site and restart the site (or wait a while) and it was working as expected

View solution in original post

Highlighted

Hello azulcore,

 

I'm having the same issue, but I don't understand your solution.

My cloud config is within the web.config file as it is on the sample application.

Could you help me with some guidance here, please?

 

Thanks in advance!

Highlighted
New Member

Under the pbiPassword key, within the app settings in Web.config, I had to add this:

 

<add key="authorityUrl" value="https://login.windows.net/common/oauth2/authorize/" />
<add key="resourceUrl" value="https://analysis.windows.net/powerbi/api" />
<add key="apiUrl" value="https://api.powerbi.com/" />
<add key="embedUrlBase" value="https://app.powerbi.com/" />

 

Got that from https://community.powerbi.com/t5/Developer/App-owns-data-Sample-Azure-Problem/td-p/425097

 

Highlighted

Hi Marcos, Did you fix the error? If yes, how did you fix it?... I'm also having the same problem, the original solution didn't work to me. Thank you!

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Community Conference

Microsoft Power Platform Communities

Check out the Winners!

secondImage

Create an end-to-end data and analytics solution

Learn how Power BI works with the latest Azure data and analytics innovations at the digital event with Microsoft CEO Satya Nadella.

Top Kudoed Authors