cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Helper I
Helper I

Power BI Custom Visual - force directed graph API error

Hi,

 

I'm trying to create a custom Force Directed Graph using the source code on Github (PowerBI-visuals-ForceGraph) and following the tutorial available at creating-a-custom-visual. Unfortunately, when I try to start the custom visual using the "pbiviz start" command in PowershellI I get an error stating "Invalid API version v2.3.0".

 

The "circlecard" example project used in the tutorial, which also uses API version v2.3.0 in it's pbiviz.json file, works just fine. So I'm clueless as to what's causing this error. I'm very new to trying out custom visuals on Power BI so any help with this is greatly appreciated.

 

Thanks in advance!

1 ACCEPTED SOLUTION
Community Champion
Community Champion

Hi,

 

To build Force Directed Graph from source code please follow these steps:

  1. $ git clone git@github.com:Microsoft/PowerBI-visuals-ForceGraph.git
  2. $ cd PowerBI-visuals-ForceGraph
  3. $ npm install
  4. $ npm run pbiviz -- --create-cert
  5. $ npm start

Let us know if it resolves the issue.

 

Ignat Vilesov,

Software Engineer

 

Microsoft Power BI Custom Visuals

pbicvsupport@microsoft.com

View solution in original post

3 REPLIES 3
Community Champion
Community Champion

Hi,

 

To build Force Directed Graph from source code please follow these steps:

  1. $ git clone git@github.com:Microsoft/PowerBI-visuals-ForceGraph.git
  2. $ cd PowerBI-visuals-ForceGraph
  3. $ npm install
  4. $ npm run pbiviz -- --create-cert
  5. $ npm start

Let us know if it resolves the issue.

 

Ignat Vilesov,

Software Engineer

 

Microsoft Power BI Custom Visuals

pbicvsupport@microsoft.com

View solution in original post

Thanks for the solution Ignat. I followed the steps but unfortunately step 3 produces the following errors:

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules\fsevents): 
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})
added 1234 packages from 1340 contributors and audited 17443 packages in 164.43s
found 2 vulnerabilities (1 low, 1 high)

Ignoring the errors/warnings and proceeding futher seems to work. However, for step 5, I had to use pbiviz start.

 

Thanks a ton for the solution!

Helpful resources

Announcements
secondImage

Happy New Year from Power BI

This is a must watch for a message from Power BI!

December Update

Check it Out!

Click here to read more about the December 2020 Updates!

Community Blog

Check it Out!

Click here to read the latest blog and learn more about contributing to the Power BI blog!

Get Ready for Power BI Dev Camp

Get Ready for Power BI Dev Camp

Mark your calendars and join us for our next Power BI Dev Camp!.