cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
marcio_fornari
Resolver I
Resolver I

Power BI API return 401 Unauthorized` response

Hello Everybody, 

I have a problem with a Power BI API

 

First i get the Token:

 

 

$url = 'https://login.windows.net/' . $directoryIdAzure . '/oauth2/token'
            /** @var GuzzleHttp\Client $client **/
            $response = $client->post(
                $url,
                [
                    "headers" => [
                        "Accept" => "application/json"
                    ],
                    'form_params' => [
                        'resource'      => 'https://analysis.windows.net/powerbi/api',
                        'client_id'     => $clientIdAzure,
                        'client_secret' => $clientSecretAzure,
                        'grant_type'    => 'client_credentials',
                        'username'      => $user,
                        'password'      => $pass,
                        'scope'         => 'openid',
                    ]
                ]
            );

            $body = json_decode($response->getBody()->getContents(), true);

            $token = $body['access_token'];

 

After i need list all Workspaces using a token

 

 

            $client2 = new \GuzzleHttp\Client();
            $res = $client2->request(
                'GET',
                'https://api.powerbi.com/v1.0/myorg/groups',
                [
                    'headers' =>
                    [
                        'Authorization' => 'Bearer ' . $token,
                        'Accept' => 'application/json',
                        'Content-type' => 'application/json'
                    ]
                ]
            );

            $workspaces = json_decode($res->getBody()->getContents(), true);

 

Return this error for me:

 

"Client error: `GET https://api.powerbi.com/v1.0/myorg/groups` resulted in a `401 Unauthorized` response"

 

The permissions in the Azure it's OK:

 

 

 

1 ACCEPTED SOLUTION
marcio_fornari
Resolver I
Resolver I

I Solved my problem.

 

I change 

'grant_type'    => 'client_credentials',

 

to 

 

'grant_type'    => 'password',

 

and I had to disable Security Defaults in the Azure 

Azure Portal > Azure AD > Properties > Click on Manage Security Defaults link > Toggle Enable Security Defaults button to NO.

 

I hope thats help anyone. 

View solution in original post

1 REPLY 1
marcio_fornari
Resolver I
Resolver I

I Solved my problem.

 

I change 

'grant_type'    => 'client_credentials',

 

to 

 

'grant_type'    => 'password',

 

and I had to disable Security Defaults in the Azure 

Azure Portal > Azure AD > Properties > Click on Manage Security Defaults link > Toggle Enable Security Defaults button to NO.

 

I hope thats help anyone. 

View solution in original post

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Power BI October Update 2021.jpg

Power BI Release

Click here to read more about the October 2021 Release!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Teds Dev Camp Oct. 2021 768x460.jpg

Power BI Dev Camp - October 28th, 2021

Mark your calendars and join us for our next Power BI Dev Camp!

Top Solution Authors
Top Kudoed Authors