cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Microsoft
Microsoft

On-Premises data gateway: Network ports test - Incomplete (Failed to connect to network)

Hi power addicts,

 

I am experiencing an ongoing problem with my data gateway. I have never been able to have a consistent scheduled refresh due to some configuration problem. I have the latest version (June 2020) installed on an Azure VM. I have created the rules in my network security group in Azure to allow open ports for the specified outbound connections. I have even turned off my VM's firewall to troubleshoot the issue. The only resolution is to kill the gateway and re-open it. But, I have to do this intermittently and at least every day if my scheduled refresh is to succeed. Yes, restarting my VM or closing and reopening the gateway always creates a successful test and connection results but the connection is never maintained after an undetermined amount of time.

 

Here is an example of a successful test and subsequent scheduled refresh yesterday (after a reboot and/or restarting the gateway). This morning, the same test fails and so does my scheduled refresh. For the record, my VM is still connected to the network with access to the public internet and my corporate domain. I have read the documentation and the community posts but cannot seem to find a solution or resolve this issue.

successful_test.pngfailed_test.png

In advance, thank you so much!

 

With gratitude,

Nick

1 REPLY 1
Highlighted
Super User V
Super User V

Re: On-Premises data gateway: Network ports test - Incomplete (Failed to connect to network)

Ignore these network port tests, they are useless in any company that properly protects and partitions their network.

 

Switch all your gateways to HTTPS, and then set  up manual proxies if needed.

 

Cause 6: Cannot register new gateway cluster member 

Solution 6: Enforce usage of proxy 

https://docs.microsoft.com/en-us/data-integration/gateway/service-gateway-proxy 

Modify the following files: 

C:\Program Files\On-premises data gateway\enterprisegatewayconfigurator.exe.config 

C:\Program Files\On-premises data gateway\Microsoft.PowerBI.EnterpriseGateway.exe.config 

C:\Program Files\On-premises data gateway\ Microsoft.Mashup.Container.NetFX45.exe.config 

With the following change to the default proxy parameter 

        <defaultProxy useDefaultCredentials="true" enabled="true"> 

        <proxy proxyaddress="http://yourproxy:port/" bypassonlocal="true" /> 

        </defaultProxy> 

Then restart the Gateway service and complete the registration. 

Helpful resources

Announcements
Get Ready for Power BI Dev Camp

Get Ready for Power BI Dev Camp

Don't miss the Power BI Dev Camp this week!

August Community Highlights

Check out a full recap of the month!

August 2020 CYST Challenge

Check out the winners of the recent 'Can You Solve These?' community challenge!

Experience what’s next for Power BI

Join us for an in-depth look at the new Power BI features and capabilities at the free Microsoft Business Applications Launch Event.