cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
gswapnil90
New Member

Images not loading in Chiclet slicers

In my report, I'm using Chiclet slicer with images to slice on Products.

My Product images are in Azure and their path is in an attribute in Product dimension in my cube.

 

Symptoms of the problem:

1. By default, on the report page, ~30-40 products show up, but images for many of the products don't show up. Only ~6 products show up with images

2. Even though all products show up in the slicer (though some are without images), the slicer shows information icon with message "Too many Values, not showing all data"

 

Note: Each image is ~5KB in size

 

 

Is this a known issue or is there anything specific that I can do to fix it?

18 REPLIES 18
Anonymous
Not applicable

In my case Power BI desktop did not show the images correctly but when I published the report it did show up. Also dont forget to change the data category of the URL column to 'Web URL' in the 'Data' tab. Click the 'Data' tab > select the column containing URLs > select Modeling > select Data Category: Web URL (Properties tab).

kaushal
Frequent Visitor

Chiclet slicer have the problem with the file names containing space. So if you replace the spaces between file name into %20 then it will work for you.

For example

 

if you have a link like

http://contoso.com/my image.jpg

then replace it to

http://contoso.com/my%20image.jpg

 

I would suggest replace all spaces containing in url with %20

 

Hope that helps

 

Kaushal

This is not working to me either. SO frustating. There are no spaces in my URL. I tried using imgur as source and Google Drive. nothing works.

 

PLEASE somebody help

dmoysidis
Frequent Visitor

Same problem here. And I'm using OneDrive stored images. I can access them fine so it's not network issue.

v-viig
Community Champion
Community Champion

Do your images require authentication?

Please also note that it'd be better to use HTTPS instead of HTTP.

 

Ignat Vilesov,

Software Engineer

 

Microsoft Power BI Custom Visuals

pbicvsupport@microsoft.com

Chiclet slicer loads images from 'http' link correctly. But doesn't load when I use 'https' link. Could anyone advise me how to deal with this issue? Sample https link looks like this: "HTTPS://16ss.https.ewe.erefwq.net.net/....../..../scr_xxx.png"  

dmoysidis
Frequent Visitor

No they don't and the URL is an HTTPS one

v-viig
Community Champion
Community Champion

Can you share at least one image link?

I just want to double check that link is correct.

 

Ignat Vilesov,

Software Engineer

 

Microsoft Power BI Custom Visuals

pbicvsupport@microsoft.com

dmoysidis
Frequent Visitor

v-viig
Community Champion
Community Champion

Capture.PNG

This link works well for me.

Could you please open your report with ?unmin=true (https://app.powerbi.com/?unmin=true) flag and share log from browser's developers tools?

 

Has this been solved?  I am having this issue today.

 

image.png

Anonymous
Not applicable

Does the image show up whenever you publish the report? Have you tried changing the data category of the URL column to 'Web URL'? 

Hi there, many thanks for the response back.

 

Sorry I neglected to mentioned I did set to use url, and have tried publishing and image still does not load.

 

I did try another PBi visual, named Image Grid, and I am still experiencing the same issue.  I feel it is more a user error on my end.

Anonymous
Not applicable

@eamorin96Are the images that you try to view in the slicer public avalaible on the internet? 

Hello everyone,

 

I ran into same problem and found the fix.

 

The free icons are not easy to find. I used flaticon.com. Now for PBI to display the icon on chiclet slicer you need to provide the embedded html information as below. However, most icon websites do not give you this option readily on the surface unlike icons8.com.

 

Capture.PNG

Fix is following

A. Choose your icon from the website.

B. I use Mozilla Firefox. So once you go to the icon page do the following

   From the top menu, select Tools > Web Developer > Page Source

B. look for img src. The embedded html can be found there. Copy paste the embedded html and put that as the URL on the icon dataset and PBI does the rest of the magic.

 

https://www.flaticon.com/free-icon/vacuum-cleaner_291367

Capture.PNG

Capture.PNG

 

Have fun guys !!!!

 





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!






New Animated Dashboard: Sales Calendar


bfischam
Regular Visitor

I am also unable to see Images loading into the Chiclet Slicers.  Is anyone else having this issue?  Is there a way to turn on the rendering?

 

ChicletImageError.PNG

Anonymous
Not applicable

Im also facing with the same issue.  

I'm having the same issue as well.

Helpful resources

Announcements
June 2022 update 768X460.jpg

Check it out!

Click here to read more about the June 2022 updates!

Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Power BI Dev Camp Session 23 768x460.jpg

Check it Out!

Mark your calendars and join us on Thursday, June 30 at 11a PDT for a great session with Ted Pattison!

June 20 episode 7 with aka link 768x460.jpg

The Power BI Community Show

Join us on June 20 at 11 am PDT when Kim Manis shares the latest on Azure Synapse analytics, the Microsoft Intelligent Data Platform, and notable Power BI Updates from Microsoft Build 2022.