cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
arpost
Advocate III
Advocate III

Help Appreciated! Need assistance with Pipeline calls using REST API

Howdy, PBI Community! I am trying to set up a Power Automate custom connector to use for Rest APIs and can successfully run API calls like Get Dataflows with my current setup, but I always get a 401 error when trying to use the Pipeline APIs. About ready to pull my hair out and hope someone can help me. 😃

 

I'm trying to use the Get Pipeline and Get Pipeline Operations calls.

 

arpost_1-1665149982642.png

 

Here's the configuration in Azure:

 

arpost_0-1665149099061.png

 

Here's the custom connector configuration:

 

arpost_0-1665149815195.png

 

7 REPLIES 7
lbendlin
Super User
Super User

Can you successfully run some of the more mature calls like workspaces?  The Pipeline calls are very new and likely stilll buggy.

Good question. I can use some of the other calls, so I guess the next question would be: has anyone successfully used the Get Pipeline call with an app registration?

Hey @arpost ,

I can see deployment pipelines 

Watsky_0-1666106677324.png

Watsky_1-1666106844197.png

 

What happens if you use the Try It button on the Get Pipelines page? 

 

Watsky_2-1666106875424.png

Are you using a service account? 

What happens when you try doing the Admin version?

 

GET https://api.powerbi.com/v1.0/myorg/admin/pipelines

 

Admin - Pipelines GetPipelinesAsAdmin - REST API (Power BI Power BI REST APIs) | Microsoft Learn


Did my answer(s) help you? Give it a kudos by clicking the Thumbs Up!
Did my post answer your question(s)? Mark my post as a solution. This will help others find the solution.

Proud to be a Super User!

Thanks for the reply, @Watsky! Good question. I am also getting a 401 when trying to use the Admin API you linked. Anything pertaining to pipelines fail for me despite the fact that I am an admin.

 

When I use the Try it! feature, I get a response as expected, which suggests to me there's a problem with the app registration in Azure. But I can't figure out what it would be since (1) other API calls using that app reg. work just fine (e.g., Get Groups, Get Dataflows) and (2) I have enabled all permissions pertaining to Pipelines (except Deploy) as instructed by MS doc.

 

arpost_0-1667309161992.png

 

Very frustrating!

Check your auth token with jwt.io - might be a missing scope.

Thanks for the reply, @lbendlin. With MS custom connectors, they manage the tokens; I just provide some of the details for the app reg; the scope I am using is openid.

 

arpost_0-1667311646102.png

 

You can raise an issue at https://issues.powerbi.com . If you have a Pro license you can consider raising a Pro ticket at https://powerbi.microsoft.com/en-us/support/pro/

Helpful resources

Announcements
Carousel_PBI_Wave1

2023 Release Wave 1 Plans

Power BI release plans for 2023 release wave 1 describes all new features releasing from April 2023 through September 2023.

Power BI Dev Camp Session 30

Ted's Dev Camp - January 26, 2023

This session will provide guidance and teach campers the skills required to build Power BI reports that support multiple languages.

Power BI Summit Carousel 2

Global Power BI Training

Make sure you register today for the Power BI Summit 2023. Don't miss all of the great sessions and speakers!

Thank you 2022 Review

2022 Monthly Feature Releases

We had a great 2022 with a ton of feature releases to help you drive a data culture.