cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Frequent Visitor

Get Reports REST api not working - Showing 400 Bad Request

Hi All,

 

I am trying to retrieve the report metadata using the REST API provided,

https://docs.microsoft.com/en-us/rest/api/power-bi/reports/getreportingroup

 

REST call tried: https://api.powerbi.com/v1.0/myorg/groups/f702bdb7-e372-4990-a828-5e5449c6f676/reports/7d36d8aa-4ae8...

 

I did register the application and got the token. All the other REST calls are working Except this... (Showing 400 Bad request).

 

Not sure what I'm missing here. Pls let me know

 

Thanks

6 REPLIES 6
Microsoft
Microsoft

Hi @pratheeban,

 

Did you use " 'Accept' HTTP header" in the request? Maybe you can try to remove it.

 

 

Best Regards,

Dale

Community Support Team _ Dale
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi @v-jiascu-msft

 

I have the same and I have no Accept header. See cURL command obtained from the postman I am using (I have modified it by manually adding "......." to remove id's):

 

 

curl -X GET \
  https://api.powerbi.com/v1.0/myorg/groups/b931........../reports/7bbf.......... \
  -H 'Authorization: Bearer eyJ0e..........' \
  -H 'Cache-Control: no-cache'

 

Hi @luismangahr@pratheeban,

 

I tested the workaround. Please set the header "Accept" to "None" explicitly. It's None in Python. Please try it and give some feedback.

 

headers = {"Authorization": token, "Accept": None}
r = requests.get(get_url, headers = headers)

Get Reports REST api not working - Showing 400 Bad Request.png

 

 

 

Best Regards,
Dale

 

Community Support Team _ Dale
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Thanks, @v-jiascu-msft, it actually worked! Then, this is a bug, right? In that case, I guess it is identified and to be solved?

 

Just to add, I found that you can set the "Accept" header to "None", "Noffsfne", "j" or any other invalid value. All valid values I quickly tested (e.g.: "application/json", "message/http" or "text/html") ended up in a "400 Bad Request".

 

But again, thank you, because this unblocks our research on the Power BI REST api.

Thanks for sharing, @luismangahr. This issue will be fixed. We can work with the workaround for now.

 

Best Regards,

Dale

Community Support Team _ Dale
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Microsoft
Microsoft

Hi @pratheeban,

 

Seems something is wrong. I have reported this issue to the Product Team: CRI 75423606. I will update here.

 

Best Regards,

Dale

Community Support Team _ Dale
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
secondImage

Congratulations!

We are excited to announce the Power BI Super Users!

Wave Release 2

Check out the updates in Power BI.

Overview of Power BI 2020 release wave 2!

Microsoft Ignite

Microsoft Ignite

Join digitally, March 2–4, 2021 to explore new tech that's ready to implement. Experience the keynote in mixed reality through AltspaceVR!

secondImage

The largest Power BI virtual conference

100+ sessions, 100+ speakers, Product managers, MVPs, and experts. All about Power BI. Attend online or watch the recordings.

Top Kudoed Authors