cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
SWang
Helper I
Helper I

GenerateTokenInGroupAsync returns "Operation returned an invalid status code 'InternalServerError"

Hello there - We are testing the Power BI Embeded in .NET Web application.  It works fine in App Owns Data, which is downloaded from Microsoft when the setup procedures in the link below.

following https://app.powerbi.com/embedsetup/AppOwnsData?session_id=52c9f614-53dc-4c35-a67f-bee33b8ec8be

 

The issue however, is that PowerBIClient.Reports.GenerateTokenInGroupAsync returns InternalServerError when copy all the codes from App Own Data project to a brand new .Net Web Application.   Both the brand new .Net Web Application and App Own Data are using .Net Framework 4.6.1, and both are using PowerBI.Api 2.4.0.19209.  However, I do notice that App Own Data does refers to some other packaged such Owin and Microsoft.Owin that my brand new app does not. Also, some system assemblies version differ from one to another. If anyone can help on identifing what are exactly needed if a developer start a brand new application, it would be greatly appreciated.  

 

The reason I need to use a brand new app is that we are planning to use PowerBI.Api 3.23 under .Net Framework 4.8.  In order to make this upgrade, I have to create a brand new app.  But in the new app, PowerBI.Api 3.23 has the same issue.  So I turned back to 2.4.0.19209 with 4.6.1 to compare with App Own Data apple by apple.  Below are screen shots of these reference for comparison.

Reference list in new appReference list in new appReference list in new appReference list in new appApp Own Data listApp Own Data listApp Own Data listApp Own Data list

1 ACCEPTED SOLUTION
SWang
Helper I
Helper I

Thanks @Lionel chen.  The issue is resolved.  It is due to a wrong url.  My mistake.  It is verified that both V2 and 3.23 work fine in both .Net Framework 4.6.1 and .Net 5.  Thanks

View solution in original post

2 REPLIES 2
SWang
Helper I
Helper I

Thanks @Lionel chen.  The issue is resolved.  It is due to a wrong url.  My mistake.  It is verified that both V2 and 3.23 work fine in both .Net Framework 4.6.1 and .Net 5.  Thanks

View solution in original post

v-lionel-msft
Community Support
Community Support

Hi @SWang ,

 

Operation returned an invalid status code 'InternalServerError' · Issue #4271 · microsoft/botframewo...

Maybe you can refer to this.

 

Best regards,
Lionel Chen

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

Top Kudoed Authors