cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Error when refreshing dataset via REST API in VB.net

Hello,

 

I'm using the following code to trigger a dataset refresh via the REST API and VB.net:

 

      Dim redirectUri, resourceUri, authorityUri, clientID As String

        redirectUri = "https://dev.powerbi.com/Apps/SignInRedirect"

        resourceUri = "https://analysis.windows.net/powerbi/api"

        authorityUri = "https://login.windows.net/common/"

        Dim authContext As New AuthenticationContext(authorityUri, New TokenCache())

        clientID = My-Client-ID

        Dim authenticationResult As AuthenticationResult

        Try

            authenticationResult = Await authContext.AcquireTokenAsync(resourceUri, clientID, New Uri(redirectUri), New PlatformParameters(PromptBehavior.Auto))

            Dim s As HttpWebRequest
            Dim enc As UTF8Encoding
            Dim postdata As String

            s = HttpWebRequest.Create("https://api.powerbi.com/v1.0/myorg/groups/My-Workspace/datasets/My-Dataset/refreshes")

            s.Method = "POST"
            s.KeepAlive = True
            s.ContentLength = 0

            s.Headers.Add("Authorization", String.Format("Bearer {0}", authenticationResult.AccessToken))
            s.ContentType = "application/x-www-form-urlencoded"

            s.GetResponse()

        Catch ex As Exception
            MessageBox.Show(ex.Message)
        End Try

 

This used to work perfectly. However suddenly I started to get an error at .GetResponse ("Connection closed..."). Does anyone have an idea where the problem could be? I updated all the involved nuget packages but that didn't help.

 

Thanks for any help!

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Frequent Visitor

In case anyone is having the same issue, I had to enable TLS 1.2 for the connection, which I did by adding this line in code:

System.Net.ServicePointManager.SecurityProtocol = System.Net.SecurityProtocolType.Tls12

Reference here and here.

 

View solution in original post

1 REPLY 1
Highlighted
Frequent Visitor

In case anyone is having the same issue, I had to enable TLS 1.2 for the connection, which I did by adding this line in code:

System.Net.ServicePointManager.SecurityProtocol = System.Net.SecurityProtocolType.Tls12

Reference here and here.

 

View solution in original post

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Community Conference

Microsoft Power Platform Communities

Check out the Winners!

secondImage

Create an end-to-end data and analytics solution

Learn how Power BI works with the latest Azure data and analytics innovations at the digital event with Microsoft CEO Satya Nadella.

Top Solution Authors