cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
jsegarra001
Regular Visitor

Embedded report force displaying titles on all visuals

I've got an issue where I'm embedding a report into an application, app owns data scenario. The report in desktop and Power BI service, looks/renders without issue. When the report is embedded into the application, all of the visuals on the report are forcefully displaying their Titles, even when the report has those set to off. Has anyone experienced this? 

 

The application code shown to me by the app dev doesn't seem to be forcing title displays. They're using Microsoft.PowerBI.API version 2.014, which they know is old. I've advised them to upgrade to v3 but they're currently under time crunch and don't have time to fix breaking changes for move to 3 yet, although I don't know if that would have any bearing on this at all.

3 REPLIES 3
Super User IV
Super User IV

Re: Embedded report force displaying titles on all visuals

I haven't seen that. You could check the Issues forum here:

https://community.powerbi.com/t5/Issues/idb-p/Issues

And if it is not there, then you could post it.

If you have Pro account you could try to open a support ticket. If you have a Pro account it is free. Go to https://support.powerbi.com. Scroll down and click "CREATE SUPPORT TICKET".


---------------------------------------

Putting square pegs in round holes since 1972.

I have a NEW book! 
DAX Cookbook from Packt
Over 120 DAX Recipes!
Did I answer your question? Mark my post as a solution!

Proud to be a Datanaut!

jsegarra001
Regular Visitor

Re: Embedded report force displaying titles on all visuals

Thanks. I'm a consultant working for this client and I don't have a pro account under their tenant. I already advised their developer to open support ticket. I'm posting here to try and be proactive and hopefully find a resolution. I searched forum already and couldn't find anything like what I'm seeing, hence the post. 

jsegarra001
Regular Visitor

Re: Embedded report force displaying titles on all visuals

Good  news, update and resolution. Turns out the web dev was applying a theme over the report within their app code. In the theme json they were setting title to true. Removed that from the json to allow the report to control that piece, looks fine now.

Helpful resources

Announcements
Announcing the New Spanish Forum

Announcing the New Spanish Forum

Do you need help in Spanish? Check out our new Spanish community section.

April 2020 Community Highlights

April 2020 Community Highlights

Info on our Super Users, MBAS content and badges, and updates to our support articles. - Read the full Community Highlights.

MBAS Gallery 2020

MBAS Gallery 2020

Watch Microsoft Business Applications Summit sessions on-demand.