cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
IPS1 Frequent Visitor
Frequent Visitor

Developer visual icon is missing

I have the same issue as in https://community.powerbi.com/t5/Developer/Developer-Visual-is-missing/td-p/207939 but it doesn't work and I do it on Power BI online site.

 

(I downloaded https://github.com/Microsoft/PowerBI-visuals-sampleBarChart/tree/master/assets. Ran npm install, pbiviz start and it claims

 

info Building visual...
done build complete

info Starting server...
info Server listening on port 8080.

 

and I made sure Enable developer visual for testing is enabled but that icon won't show up when I open a PowerBI report for edit on https://app.powerbi.com. I do it in my private workspace.)

 

Any idea please?

1 ACCEPTED SOLUTION

Accepted Solutions
Moderator v-viig
Moderator

Re: Developer visual icon is missing

It works on my side in the same Google Chrome version.

 

We'd recommend to try this solution out:

  • Open Power BI service in Chrome
  • Press F12
  • Open the Console tab
  • Type "localStorage.clear()"
  • Press Enter
  • Go to Setting 
  • Open Developer tab
  • Turn on "Enable developer visual for testing"
  • Open any data set

image.png

 

As an alternative solution we'd also recommend to try debug visual in other browsers.

 

Ignat Vilesov,

Software Engineer

 

Microsoft Power BI Custom Visuals

pbicvsupport@microsoft.com

4 REPLIES 4
Moderator v-viig
Moderator

Re: Developer visual icon is missing

What web browser and what version of web browser do you use?

 

Ignat Vilesov,

Software Engineer

 

Microsoft Power BI Custom Visuals

pbicvsupport@microsoft.com

IPS1 Frequent Visitor
Frequent Visitor

Re: Developer visual icon is missing

Hi,

 

Google Chrome66.0.3359.181 (Official Build) (64-bit) (cohort: Stable)
Revisiona10b9cedb40738cb152f8148ddab4891df876959-refs/branch-heads/3359@{#828}
OSWindows
JavaScriptV8 6.6.346.32

 

Thank you

Moderator v-viig
Moderator

Re: Developer visual icon is missing

It works on my side in the same Google Chrome version.

 

We'd recommend to try this solution out:

  • Open Power BI service in Chrome
  • Press F12
  • Open the Console tab
  • Type "localStorage.clear()"
  • Press Enter
  • Go to Setting 
  • Open Developer tab
  • Turn on "Enable developer visual for testing"
  • Open any data set

image.png

 

As an alternative solution we'd also recommend to try debug visual in other browsers.

 

Ignat Vilesov,

Software Engineer

 

Microsoft Power BI Custom Visuals

pbicvsupport@microsoft.com

IPS1 Frequent Visitor
Frequent Visitor

Re: Developer visual icon is missing

Thank you, I followed the steps and now it works in my Chrome.