cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
oski Frequent Visitor
Frequent Visitor

Debug Assert Failed: The API Version 2.1.0 is Invalid

 

BTW, all technical details that I think would be helpful are below, system, software versions, etc.

 

Anyway, I followed a tutorial on creating a custom viz on my mac. It sucessfully rendered in power bi (the website)

 

Screen Shot 2018-10-17 at 7.25.59 PM.png

 

 

After this I ran pbiviz package. And it appeared to work ok. It created the pbiviz with the circleCard.pbiviz inside the dist folder.

But when I went to my test machine, which is Parallels version of Windows and tried to import into Power Bi Desktop I got two key messages.

 

1. Debug Assert Failed: The API Version 2.1.0 is Invalid

2. You version of Power BI Desktop does not support custom visuals.

 

 

 

 

Screen Shot 2018-10-17 at 6.53.47 PM.png

 

 

What did I try so far?

 

1. In the pbiviz json file I set it to 2.1.1, which is the version of pbiviz that I'm using.

$ pbiviz package
info Building visual...
error VALIDATION Invalid API Version v2.1.1

 

Anybody have any ideas on how to fix this? 

 

Thanks!

 

 

Code 

https://github.com/markarios/circleCard

 

Development Computer

Mac Os Sierra 10.12.6

pbiviz --version 2.1.1

 

 

Portal Used For Previewing Custom App

app.powerbi.com

Version 13.0.6980.207 

 

Test Computer

Windows 8.1 Enterprise

Microsoft Power BI Desktop (Optimized for Power BI Report Server - August 2018)

Power BI Version: 2.61.5192.641 64-bit (August 2018)

 

 

 

2 REPLIES 2
Moderator v-viig
Moderator

Re: Debug Assert Failed: The API Version 2.1.0 is Invalid

API 1.11.0 should work fine with August release of Power BI Desktop.

 

Ignat Vilesov,

Software Engineer

 

Microsoft Power BI Custom Visuals

pbicvsupport@microsoft.com

oski Frequent Visitor
Frequent Visitor

Re: Debug Assert Failed: The API Version 2.1.0 is Invalid

 

 

Screen Shot 2018-10-19 at 11.58.09 AM.png