cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Continued Contributor
Continued Contributor

Calling ActivityEvents API from Logic Apps - Returns Empty Array

I've setup a Logic App that's running a Custom Connector loaded with the Activity Events API. 

The Logic App works - in that it calls the API for a single date - and returns a continuation token. 

I use decodeURIComponent - and feed the continuationtoken back to the API - and ask it to loop until "lastresultset" = true. 

The timeout is set to 60.  

 

The app cycles 60 times - and always returns the same result (which looks identical to the first run). 

{"activityEventEntities":[],"continuationUri":"https://wabi-us-north-central-redirect.analysis.windows.net/v1.0/myorg/admin/activityevents?continuationToken='LDIw************uMDAwWiwyMDIwLTExLTE4VDIzOjU5OjU5Ljk5OVosMSws'","continuationToken":"LDIw************uMDAwWiwyMDIwLTExLTE4VDIzOjU5OjU5Ljk5OVosMSws","lastResultSet":false}

I'm unsure why it continues to return an empty array [] each time.  

The date I've chosen is a Wednesay - and I know there should be data.

 

Any ideas?

0 REPLIES 0

Helpful resources

Announcements
secondImage

Experience what’s next for Power BI

Join us for an in-depth look at the new Power BI features and capabilities at the free Microsoft Business Applications Launch Event.

secondImage

Power BI Women

Join our monthly meetings and learning sessions.

secondImage

Congratulations!

We are excited to announce the Power BI Super Users!

secondImage

The largest Power BI virtual conference

100+ sessions, 100+ speakers, Product managers, MVPs, and experts. All about Power BI. Attend online or watch the recordings.