cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Leann
Regular Visitor

stucking on creating connection in model

Hi,

I have a data model in power bi desktop, the tables are loaded from ssas server, and it refreshed data well yesterday.

But today when I pulled in more data (400,000 rows to 17,986,280 rows) to ssas server, and click refresh data of the fact table (refresh only one table), it's stucking in "Creating connection in model" 1 hour...(still stucking)

Also, I've exmained the table which has no blank columns. is it normal? 

or any experience to check the problem efficiently?

 

Thanks a lot!

1 ACCEPTED SOLUTION
v-yuezhe-msft
Microsoft
Microsoft

@Leann,

Do  you choose “Import” or “Connect Live” mode to connect to SSAS database in Power BI Desktop? I would recommend uncheck the following options in Power BI Desktop and then refresh your data model.
1.JPG

If the above error still occurs, please try to re-connect to the SSAS database in Power BI Desktop, pull in columns and rows you need to build report.


Regards,
Lydia

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

23 REPLIES 23
soumi
New Member

hello guys , 

 

Could someone help me please , it has been a week i'm struggling wtih this issue , i haven't found a solution 

 

i've PBI installed on the virtual machine (VMW) & i'm trying to connect it with a CSV file but when i select my file it shows me the table as well , then i press  "Transform data " , it opens me the power query but when i press" close" the loading phase never ends.

 

Thanks in advance 

 

ASMAA

wcarter
Frequent Visitor

I have this same issue, though I think it is not that the data isn't loading for me but that it only shows the Creating Connection message the entire time it is loading data. It seems like some bug or change has resulted in users no longer seeing the number of rows loaded during a refresh and instead only this mesasge for all tables.

I have exactly the same issues - on all my Power BI files for a variety of data sources. It just started in September for some reason.

Everything loads but I cant see the progress of x many rows from x , its a real nuiscance as I cant gauage mcuh longer it has to run - unless I set a timer on my phone. Please fix this

Yes I believe you may be right. I got the 'Creating Connection' message and the data was loaded into my model. I then checked my model and the connections were not made. Seems like a bug on the message but didn't keep me from loading in data and the load did not take long

Faadiz
Frequent Visitor

Hello,

 

i tried above also + unchecked "Creating Connection in Model" but its not working?

 

Its after Septmber update.

 

Please help. Data Loads into Power Query but when i apply the changes, it is stuck.

 

Fahd,

Hello Fahd, 

 

i've the same issue , could you tell me please how did u figure this out 

 

thank u 

Did you ever get this resolved?

timmay
Frequent Visitor

I solved my same issue just FYI for anyone who has tried the above fixes but is still experiencing "Creating connection in model".

 

I recently moved all my measures into the one measure group and created folers for them.  This means that the old measure group was left behind with no measures in it and they were hidden from view.

 

these measure groups would give and error on refresh (scroll down on refresh and you can see the error).

 

On going to the model tab in pbi I could see these measure groups without any measures in them.  I just deleted these and this resolved the issue!

v-yuezhe-msft
Microsoft
Microsoft

@Leann,

Do  you choose “Import” or “Connect Live” mode to connect to SSAS database in Power BI Desktop? I would recommend uncheck the following options in Power BI Desktop and then refresh your data model.
1.JPG

If the above error still occurs, please try to re-connect to the SSAS database in Power BI Desktop, pull in columns and rows you need to build report.


Regards,
Lydia

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

This is still not resolved even after October Update.

i tried every thing mentioned in this thread.

 

I have August Version Installed and it works perfectly fine.

 

But the Version from Microsoft Store (Oct 2021) still having issues and is stuck at Creating Connection.

 

Please help! @v-yuezhe-msft 

Hello,

 

Tried the Solution above, still doeswn't work. Stuck at Creating Connection in Model.

This is happening after September2021 update of PowerBI Desktop.

I tried degrading to previous version of Power BI Desktop(August2021) Version. It is fixed now.

 

Regards,

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

OK so its obviously from the upgrade as it happend to all my files in since September to.. but it still needs fixing. But at least I know now thank you.

I am stuck on this as well. Tried following above steps but didn't resolve the issue. I would rather not downgrade my version. 

How did you downgrade the version?

@mdyavanapalli 
You need to uninstall your current desktop version, then download one of these versions to re-install

August 2021 version of Power BI Desktop - 64-bit:

https://download.microsoft.com/download/8/8/0/880BCA75-79DD-466A-927D-1ABF1F5454B0/PBIDesktopSetup-2...

August 2021 version of Power BI Desktop - 32-bit:
https://download.microsoft.com/download/8/8/0/880BCA75-79DD-466A-927D-1ABF1F5454B0/PBIDesktopSetup-2...

beware of "--comments"

Still no luck after doint that. only difference is mine works and loads but its stopped telling me how many rows are being loaded?

 

Hi Lyida@v-yuezhe-msft

Thanks a lot for your help. After I disable the features you mentioned plus "import relationship from data source", I can load the table smoothly. 🙂

I found the cause might be the new source of the dimension table contains duplicate rows, it caused the hang on problem.

one more question, if I refresh the data from power bi service, will it check the relationship as well? or is related to what I set in the option power bi desktop? Thanks for your answer.  🙂

 

Have a nice weekend! 

LeAnn

I have the same problem, I followed the same steps as in your proposed solution, but i'm still having issues refreshing the data.

 

Can anyone help me?

I cannot refresh my data. Creating connection in model never finishes. See printscreen. Data source settings are adjusted due to changed network name but oke now. It has always worked before.

 

2020-01-28 11_52_12-Purchasing_spend_and_savings - Power BI Desktop.png

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

November Power BI Update 768x460.png

Check it Out!

Click here to read more about the November 2021 Updates!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.