cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Bkmet
Frequent Visitor

"Do not summarize" missing

I am trying to build a bubble scatter chart with a field (in this case, a non-additive ratio) I do not want to aggregate.  However, Power BI seems to default to summing this field, but I do not want any aggregation.

 

in a help document, it indicates that "Do not summarize" is supposed to be an aggregation option, but this selection does not appear when I attempt to change the aggregation type for the field I'm interested in; in this case, a ratio.  

 

Any ideas on how I might apply this setting to the field in question?  Why is "Do not summarize" not appearing as an aggregation option?  The field is numeric and its data source is an Excel file. 

 

Thank you for your assistance to a newbie question.  

7 REPLIES 7
Sean
Community Champion
Community Champion

@Bkmet Look in these 2 places... You will also not see this option if your DATA TYPE is TEXT

Do Not Sum.png

Bkmet
Frequent Visitor

Thanks, I will examine these 2 places. I am trying to NOT aggregate a field (which is a numeric ratio and should not be aggregated) which I want to display on the y-axis of a scatter/bubble chart.  The "Do not summarize" option is not available; I suspect I have a data type issue or am trying to NOT aggregate in a manner that does not make sense to do so.  I will play around with this and see what I can do.  

Bkmet
Frequent Visitor

Unfortunately, this is not working for me.  I have two fields in my data set that I wish to scatter plot.  One field is "population", the other "number of injuries".  Both fields are whole numbers.  The population field represents the population of a given state, such as California.  Regardless of the data being presented in the scatter plot, the population remains the same.  Therefore, I do not want to aggregate it.  

 

In the scatter plot, I do not want to aggregate the population field.  I have set the Default Summarization = "Do not summarize".  However, when I place this field on the Y-axis within the scatter plot, it continues to "Sum" the values in "population".

 

Furthermore, "Do not summarize" is not appearing as an aggregation option.

 

I'm likely missing something obvious, but in a scatter plot, you often do not want to aggregate an axis, depending on the nature of the data.  It's a bit frustrating to produce something so very simple.

 

Any ideas are welcome.

Sean
Community Champion
Community Champion

@Bkmet Are you sure the values are aggregated?

 

Look => State is in the Legend => so CA remains at 40 mil even though it says SUM

 

Population SUM.png

 

If you remove the State field THEN the Population field will be aggregated

 

Population SUM2.png

@Bkmet - Can you post a screen shot of your scatter plot visual configuration in terms of what data is in the axis, values, etc? I am having difficulty understanding the exact requirement here in terms of what you are looking to solve and what you are trying to plot. Some sample data would be very helpful as well. If the population never changes regardless, perhaps try "Average" as the aggregation or perhaps Min or Max. So, average of 1000, 1000, and 1000 is 1000 as will be the aggregate answer of min and max aggregations.


@ me in replies or I'll lose your thread!!!
Check out my External Tool for Power BI Desktop! Microsoft Hates Greg's Quick Measures
YouTube Channel! Microsoft Hates Greg
Check out my latest book!

Greg_Deckler
Super User
Super User

Are you in the data modeling area, the Modeling tab, on the far right is "Default summarization", that is where you should find "Do not summarize" that you can set within the data model and it should then apply to anywhere you use that column in a visual.


@ me in replies or I'll lose your thread!!!
Check out my External Tool for Power BI Desktop! Microsoft Hates Greg's Quick Measures
YouTube Channel! Microsoft Hates Greg
Check out my latest book!

ankitpatira
Community Champion
Community Champion

@Bkmet It depends on which area of visual you're dropping that field into. Most of the visual will sum up filed if you have that field set as whole number. If you're using table or matrix then you will have option to 'Do not summarize' which will show you all the values but if you're using column or pie or scatter chart it make sense that you should not display individual values but sum of it.

 

So in your case if you're trying to put that field into Legend area (for example) then you need to go to Edit Queries -> select your field -> change data type to Text. This will let you display individual values in legend in scatter chart however if you have many values it will give error saying too many values.

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

November Power BI Update 768x460.png

Check it Out!

Click here to read more about the November 2021 Updates!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.