cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted

"DONT SUMMARIZE" NOT WORKING

Hi Everyone, 

 

I would like to ask a why Power BI associative model isn't getting this. 

I have Rate by Process and full price of it.

 

1) Rate by process is not correct on this first image as it's been summarized. However, Price is correct.

1.JPG

 

2) If I hit the field option "Do not Summarize", it gets the Rate correct and messes up the price, as you can see below. 

Need help please! 

Thank you

2.JPG

1 ACCEPTED SOLUTION

Accepted Solutions
HotChilli Established Member
Established Member

Re: "DONT SUMMARIZE" NOT WORKING

'Rate by process' has a sigma character next to it - meaning powerbi wants to total and summarize it.  I suspect you just changed 'Do Not Summarize' in the field well of the report rather than on the Modelling tab of Data view.

Try this , the sigma should disappear

 

 

5 REPLIES 5
HotChilli Established Member
Established Member

Re: "DONT SUMMARIZE" NOT WORKING

Where do the 2 fields come from?  We need to see the tables and any relationship between them.

Re: "DONT SUMMARIZE" NOT WORKING

here's the relationship. THANK YOU. 

2.JPG

HotChilli Established Member
Established Member

Re: "DONT SUMMARIZE" NOT WORKING

'Rate by process' has a sigma character next to it - meaning powerbi wants to total and summarize it.  I suspect you just changed 'Do Not Summarize' in the field well of the report rather than on the Modelling tab of Data view.

Try this , the sigma should disappear

 

 

Re: "DONT SUMMARIZE" NOT WORKING

It worked partially. Thanks for that. 

However, I face a new challenge. My column "Preço (€)" is = to 'Rate Processo' * 'Orcamento'. Problem is that I am getting these values from two different tables and therefore the process repeats more than once. as you can see below, 'Custo_User_Calc' when it shows twice, somehow 'Preço (€)' column multiplies per 'Custo_User_Calc' occurence. Do you know how to avoid this?

1.JPG

HotChilli Established Member
Established Member

Re: "DONT SUMMARIZE" NOT WORKING

I'm not sure what custo_user_calc is.  

 

I see you have many-to-many relationships in your model so it looks like powerbi is returning the information you need (but also bringing back data you don't want). You might need to change your relationships OR give powerbi more information so it can bring back the info you want, for example, in the picture you showed me, which line is the correct one?