cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
emveha
Resolver II
Resolver II

publishing is complete, however we couldn't refresh your dataset

hi all,

this morning i have modified one of my datasets with the desktop version and after i saved the modifications i published the dataset to the webversion. Before closing the desktopversion, i got the message: "publishing is complete. However we couldn't refresh your dataset". Did a manually refresh with the desktop version which went well, but if i go to the web, i can run "refresh now" but nothing happens. Tried a different dataset and the strange thing is that i managed to update this dataset but others didn t update as well (it does not give any error messages and does not show that you have started a refresh on demand...). Checked the on-prem gateway with the most recent version and they both seems to be the same (both have version 14.16.6584.1).... 

Any ideas what to do???

thanks in advance
M

1 ACCEPTED SOLUTION
Anonymous
Not applicable

Hi there,

I have the same issue, I managed to get a workaround but it's not perfect. 

 

So I store .pbix file on a SharePoint for a Version Control.

I went to Power BI Service -> Get data -> Files (Get) -> Pointed to my SharePoint location and it successfully published the report. But now I have two reports with same name... so it's not ideal.

 

I'm also wondering how this issue could be fixed.

View solution in original post

25 REPLIES 25

Hi Alba,

 

I am trying to delete my dataset from service but not be able to delete so in that case what should we do??

 

TIA

Anonymous
Not applicable

Hi there,

I have the same issue, I managed to get a workaround but it's not perfect. 

 

So I store .pbix file on a SharePoint for a Version Control.

I went to Power BI Service -> Get data -> Files (Get) -> Pointed to my SharePoint location and it successfully published the report. But now I have two reports with same name... so it's not ideal.

 

I'm also wondering how this issue could be fixed.

This solution was not the right solution for me. 

 

When I had this error I had to go into Power BI desktop and clear the Cache items.

 

This is found under 

File -> Options and Settings -> Options -> Data Load 

Then Clear the

1. Data Cache Management Options

2. Q&A Cache Options

3. Folded Artifacts Cache Options

 

only after doing this did my report publish with out this error.

Mike_Carlo_0-1610493155204.png

 

 

Mike Carlo ( https://powerbi.tips )
mike@PowerBI.Tips

apart from workaround do we have the permanent souliton for this? any update fix issue link? 

hi MXD,

 

thanks for the workaround, if there is no other solution offered i will certainly give your solution a try. Hope there is a solution for this, checked again all datasource connections within the datagateway and they seems to be working properly.... As Power bi is a part of Office365, i hope there were no changes on that level that could affect the way of working in PBI.... Anyway, let's wait if there is a good solution...

thanks!!

 

Helpful resources

Announcements
Carousel_PBI_Wave1

2023 Release Wave 1 Plans

Power BI release plans for 2023 release wave 1 describes all new features releasing from April 2023 through September 2023.

Power BI Summit Carousel 2

Global Power BI Training

Make sure you register today for the Power BI Summit 2023. Don't miss all of the great sessions and speakers!

Thank you 2022 Review

2022 Monthly Feature Releases

We had a great 2022 with a ton of feature releases to help you drive a data culture.