cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
emveha
Resolver II
Resolver II

publishing is complete, however we couldn't refresh your dataset

hi all,

this morning i have modified one of my datasets with the desktop version and after i saved the modifications i published the dataset to the webversion. Before closing the desktopversion, i got the message: "publishing is complete. However we couldn't refresh your dataset". Did a manually refresh with the desktop version which went well, but if i go to the web, i can run "refresh now" but nothing happens. Tried a different dataset and the strange thing is that i managed to update this dataset but others didn t update as well (it does not give any error messages and does not show that you have started a refresh on demand...). Checked the on-prem gateway with the most recent version and they both seems to be the same (both have version 14.16.6584.1).... 

Any ideas what to do???

thanks in advance
M

1 ACCEPTED SOLUTION
mxd
Frequent Visitor

Hi there,

I have the same issue, I managed to get a workaround but it's not perfect. 

 

So I store .pbix file on a SharePoint for a Version Control.

I went to Power BI Service -> Get data -> Files (Get) -> Pointed to my SharePoint location and it successfully published the report. But now I have two reports with same name... so it's not ideal.

 

I'm also wondering how this issue could be fixed.

View solution in original post

18 REPLIES 18
crissygamelson
New Member

Is there a solution for this? I am running into this same issue and tried all the workarounds listed above with no success. I have never run into this before and it's currently affecting 4 of my reports. 

ThePiecesFit
Advocate I
Advocate I

This fixed it for me. Editing the credentials. 

 

ThePiecesFit_0-1631317051286.png

 

same here today, the error came again out of a suddon, for different reports / sources / workspaces. 

Adjusting the workspace is not an option anymore.

 

In Desktop > data source settings > for all sources changed privacy from "none" to "organizational" - et voila.

NikGT
Frequent Visitor

We are also facing the same issue. Tried all of the suggested workarounds but non of them solved the issue. 

hemantbadgujar9
New Member

I tried all the solutions mentioned but no help till now! still facing the same error! can someone please help? 

Barendnu
Advocate II
Advocate II

We encountered the same issue. Additionally, the service gave this error when trying to refresh online: "The refresh operation failed because it took more than 120 minutes to complete. Consider reducing the size of your dataset or breaking it up into smaller datasets."

 

We tried the suggestions above but without success. If you have embedded / premium capacity, you could try turning this setting off and on again, this fixed it for us:

 

ScreenShot.PNG

I had the issue of the topic, it said that it published but could not refesh, practically no changes were deployed to PBI service.

Dropping the dataset is not an option.

Tried to clean the cache without success.

For Me it helped to turn off and on again the premium capacity setting of the workspace.

 

What's the reason for that error? I didn't have that before and I was able to publish it without problems to other workspaces.

One thing I tried with the dataset before was the "large dataset sotrage format", which I turned off again before.

aggregator3000
Frequent Visitor

We had this issue today, the workarounds didn't work however I found another one..

Clearing Cache did not work, and republishing fresh datasets is not practical as all of the report hyperlinks will change for our consumers.

In the PowerBI Service, I went to

        >Datasets

        >Q&A

        >Turn on Q&A to ask natural language questions about your data

        >Switch it off via tickbox

You also have to update your .PBIX Desktop file via the following steps, as it will just push the setting back in over the top

        >Options

        >Preview Features

        >Q&A for Live connected Analysis Services databases

Workaround successful..

 

Note, I had cleared the QA cache which was over 1GB, however that step in isolation made no difference

Chamonix
Regular Visitor

I encountered similar situation and tried the solutions above but they didn't work.
The solution in my case is related to the permissions.

In Power BI Desktop -> File ->Options and Setting->Data Source Setting
Global Permissions->Edit permissions

Just relogin all the Organization account and problem solved.

I had the same issue and this fixed it for me! Very easy fix: one of my data sources was set to anonymous instead of organization sign in--logging in with organizational account fixed it. Thanks! 

Anonymous
Not applicable

Little late to the party but I ran into this issue this morning with one of my reports. I resolved this by deleting the query cache and disabling query caching. 

Anonymous
Not applicable

I have the same issue, except it also won't refresh from the web service. I end up having to delete the report and dataset and re-upload, or publish under a different name. This is a major issue as it creates a break from the reports to all the pinned visuals on the dashboards.

 

This has happened roughly half a dozen times but only in the last few months, never had this problem before, over the 12m I've been using BI.

 

The 'Solution' currently given in this topic isn't a workable solution only a workaround which isn't really sustainable.

what you also could do is to open the pbix in desktop, go to the datasourcesettings and delete the one that is giving issues. After deleting create a new one and the dataset will still be working. Publish the Pbix and all reports are still okay.... In my case it worked.

albaantony
Regular Visitor

Hi 
I have faced the same issue a couple of times. Would like to have a solution for this. I always delete the dataset from the Power BI workspace and then re publish it. It works for me. 
Cheers, Alba

mxd
Frequent Visitor

Hi there,

I have the same issue, I managed to get a workaround but it's not perfect. 

 

So I store .pbix file on a SharePoint for a Version Control.

I went to Power BI Service -> Get data -> Files (Get) -> Pointed to my SharePoint location and it successfully published the report. But now I have two reports with same name... so it's not ideal.

 

I'm also wondering how this issue could be fixed.

View solution in original post

This solution was not the right solution for me. 

 

When I had this error I had to go into Power BI desktop and clear the Cache items.

 

This is found under 

File -> Options and Settings -> Options -> Data Load 

Then Clear the

1. Data Cache Management Options

2. Q&A Cache Options

3. Folded Artifacts Cache Options

 

only after doing this did my report publish with out this error.

Mike_Carlo_0-1610493155204.png

 

 

Mike Carlo ( https://powerbi.tips )
mike@PowerBI.Tips

apart from workaround do we have the permanent souliton for this? any update fix issue link? 

hi MXD,

 

thanks for the workaround, if there is no other solution offered i will certainly give your solution a try. Hope there is a solution for this, checked again all datasource connections within the datagateway and they seems to be working properly.... As Power bi is a part of Office365, i hope there were no changes on that level that could affect the way of working in PBI.... Anyway, let's wait if there is a good solution...

thanks!!

 

Helpful resources

Announcements
PBI_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!