cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Frequent Visitor

power BI desktop will only launch as administrator

I've just installed 64-bit PowerBI Desktop but when it tried to launch it hangs on 'Initializing model' and a message pops up to say it could not start due to errors with named pipe connections. Then if you click close the 'Initializing model' window remains and the only way to remove it is via ending task in Task Manager.

 

It does provide a link which suggests solutions if I'm running previous versions of the Power BI Enterprise Gateway (which I'm not at all). It also suggests running PowerBI Desktop as an administrator - this works but it shouldn't be required.

 

Any suggestions how to fix?

 

I'm running it on a Windows 10 PC that well exceeds requirements. I have tried uninstall/reinstall but get the same issue. However I have successfully installed on another PC without any problems.

 

1 ACCEPTED SOLUTION

Accepted Solutions

For the benefit of anyone else that suffers from this problem, there doesn't appear to be a fix for this currently, but there is a workaround. I sent a frown and got a response just saying to use the suggested solutions in the link.

 

The easiest way to do this is to right click on the Power BI Desktop desktop shortcut, go to Properties, then Compatibility then tick the box for 'Run this program as an administrator'. You get prompted every time you open it, but at least it allows you to open .pbix files directly.

View solution in original post

10 REPLIES 10
Microsoft
Microsoft

Hi  _Adrian,

 

Could you please share more details regarding the error message?

From the description, it seems to be related with the installed Enterprise gateway., check the article below and see if it would help:

Resolve Issues when Power BI Desktop will not launch

Please post back if you need any further assistance.

Regards

Hi Michael,

 

Thanks for the reply. The Error message I get is:

Microsoft Power BI Desktop could not start properly due to errors with named pipe connections. Please click on the link below for details:

https://powerbi.microsoft.com/en-us/documentation/powerbi-desktop-error-launching-desktop/

 

I have never installed Power BI Enterprise Gateway, so suggested resolutions 1&2 are irrelevant, and given that I successfully installed Power BI without the need for Gateway on a different machine, I shouldn't need to install Gateway on this machine. 

 

I can open Power BI as administrator but this is a pain so was hoping to find a different resolution.

 

Regards,

 

Adrian

Hi _Adrian,

 

Do you find a solution for this problem? I have the same problem, but I don't understand why on another PC works good, and on this one no. They are the same PC. 

 

Thank you for your help,

 

Anna

Hi Anna91,

 

I persevered with the issue and hoped it would get resolved in a later updated version... which it did. 

 

I'm currently using version 2.40.4554.463 64-bit (October 2016) which works fine for me.

 

Good luck!

 

Regards,

 

Adrian

Hi,

 

I am running the latest 32-bit version of Power BI Desktop:  Version: 2.41.4581.361 32-bit (November, 2016)

 

I get the error message when launching Power BI Desktop:

Microsoft Power BI Desktop could not start properly due to errors with named pipe connections.

 

I have tried un-installing and re-installing the Power BI Desktop application.

I also do not have the Power BI Enterprise Gateway installed on my local machine.

 

Lastly, I have also attempted to delete all existing Data Sources from the Power BI desktop.

However, the problem still persists.

 

Would appreciate any help or advice, please.  Thank you.

Argghhh! I have this same problem again, as per the original post, but after the November 2016 update.

 

Have you (or anyone else) found a fix for this?

 

Does anyone from Microsoft monitor this forum? If not, how can I flag the issue to them?

 

Cheers,

 

Adrian

Would appreciate further assistance with this issue. Still exactly as described. Running as administrator does allow me to open Power BI Desktop but this is still frustrating: It means files have to be opened from within Desktop and only after starting it as administrator. If you forget and double click on a .pbix file in windows explorer, this issue happens.

 

For the benefit of anyone else that suffers from this problem, there doesn't appear to be a fix for this currently, but there is a workaround. I sent a frown and got a response just saying to use the suggested solutions in the link.

 

The easiest way to do this is to right click on the Power BI Desktop desktop shortcut, go to Properties, then Compatibility then tick the box for 'Run this program as an administrator'. You get prompted every time you open it, but at least it allows you to open .pbix files directly.

View solution in original post

Just popping by to say 'me too'!

 

What's really annoying in our case is that we have Power BI Desktop installed on two different RDS servers - it launches just fine for regular users on one of them, but won't launch on the other one unless it's run as administrator. Obviously all my RDS users can't be admins on the RDS server.

 

Same as others, we have never had a Power BI On-premises data gateway installed on this server, so there should be no named pipe restrictions set.

Helpful resources

Announcements
November Update

Check it Out!

Click here to read more about the November 2020 Updates!

Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

secondImage

Power Platform October Community Highlights

Check out the top community contributors across all of the communities

secondImage

Create an end-to-end data and analytics solution

Learn how Power BI works with the latest Azure data and analytics innovations at the digital event with Microsoft CEO Satya Nadella.

Top Solution Authors
Top Kudoed Authors