cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Regular Visitor

on-premises data gateway install problem

I am trying to install the On-Premises Data Gateway but the installation fails. I think I have done most of the things suggested in these forums. Can someone look at the information from the install log and tell me what i have to do to get a good install?

 

SFXCA: Binding to CLR version v4.0.30319
Calling custom action Microsoft.DataTransfer.EgwInstallUtils!Microsoft.PowerBI.EgwInstallUtils.CustomActions.StartServiceToCreateUser
StartServiceToCreateUser System.ServiceProcess.TimeoutException: Time out has expired and the operation has not been completed.
at System.ServiceProcess.ServiceController.WaitForStatus(ServiceControllerStatus desiredStatus, TimeSpan timeout)
at Microsoft.PowerBI.EgwInstallUtils.CustomActions.RestartServiceImpl(String serviceDisplayName, String processName, TimeSpan actionTimeout)
at Microsoft.PowerBI.EgwInstallUtils.CustomActions.StartServiceToCreateUser(Session session)
MSI (s) (DC:DC) [15:03:18:999]: Doing action: AddLogonAsServiceRight
MSI (s) (DC:DC) [15:03:18:999]: Note: 1: 2205 2: 3: ActionText
Action ended 15:03:18: StartServiceToCreateUser. Return value 1.
MSI (s) (DC:7C) [15:03:19:003]: Invoking remote custom action. DLL: C:\Windows\Installer\MSI2ECE.tmp, Entrypoint: AddLogonAsServiceRight
Action start 15:03:18: AddLogonAsServiceRight.
SFXCA: Extracting custom action to temporary directory: C:\Windows\Installer\MSI2ECE.tmp-\
SFXCA: Binding to CLR version v4.0.30319
Calling custom action Microsoft.DataTransfer.EgwInstallUtils!Microsoft.PowerBI.EgwInstallUtils.CustomActions.AddLogonAsServiceRight
Adding logon service right for user, NT SERVICE\PBIEgwService
MSI (s) (DC:DC) [15:03:19:588]: Doing action: AddServiceUserToPerfGroup
MSI (s) (DC:DC) [15:03:19:588]: Note: 1: 2205 2: 3: ActionText
Action ended 15:03:19: AddLogonAsServiceRight. Return value 1.
MSI (s) (DC:D8) [15:03:19:591]: Invoking remote custom action. DLL: C:\Windows\Installer\MSI3111.tmp, Entrypoint: AddServiceUserToPerfGroup
Action start 15:03:19: AddServiceUserToPerfGroup.
SFXCA: Extracting custom action to temporary directory: C:\Windows\Installer\MSI3111.tmp-\
SFXCA: Binding to CLR version v4.0.30319
Calling custom action Microsoft.DataTransfer.EgwInstallUtils!Microsoft.PowerBI.EgwInstallUtils.CustomActions.AddServiceUserToPerfGroup
Exception thrown by custom action:
System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.Runtime.InteropServices.COMException: The specified account name is already a member of the group.

--- End of inner exception stack trace ---
at System.DirectoryServices.DirectoryEntry.Invoke(String methodName, Object args)
at Microsoft.PowerBI.EgwInstallUtils.CustomActions.AddUserToLocalGroup(String userName, String groupName)
at Microsoft.PowerBI.EgwInstallUtils.CustomActions.AddServiceUserToPerfGroup(Session session)
--- End of inner exception stack trace ---
at System.RuntimeMethodHandle.InvokeMethod(Object target, Object arguments, Signature sig, Boolean constructor)
at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object parameters, Object arguments)
at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object parameters, CultureInfo culture)
at Microsoft.Deployment.WindowsInstaller.CustomActionProxy.InvokeCustomAction(Int32 sessionHandle, String entryPoint, IntPtr remotingDelegatePtr)
CustomAction AddServiceUserToPerfGroup returned actual error code 1603 but will be translated to success due to continue marking
MSI (s) (DC:DC) [15:03:26:945]: Doing action: RestartService
MSI (s) (DC:DC) [15:03:26:945]: Note: 1: 2205 2: 3: ActionText
Action ended 15:03:26: AddServiceUserToPerfGroup. Return value 1.
MSI (s) (DC:30) [15:03:26:949]: Invoking remote custom action. DLL: C:\Windows\Installer\MSI4DD1.tmp, Entrypoint: RestartService
Action start 15:03:26: RestartService.
SFXCA: Extracting custom action to temporary directory: C:\Windows\Installer\MSI4DD1.tmp-\
SFXCA: Binding to CLR version v4.0.30319
Calling custom action Microsoft.DataTransfer.EgwInstallUtils!Microsoft.PowerBI.EgwInstallUtils.CustomActions.RestartService
MSI (s) (DC!20) [15:03:59:567]: Product: EgwComponents -- 1: {"ClassName":"System.ServiceProcess.TimeoutException","Message":"Time out has expired and the operation has not been completed.","Data":null,"InnerException":null,"HelpURL":null,"StackTraceString":" at System.ServiceProcess.ServiceController.WaitForStatus(ServiceControllerStatus desiredStatus, TimeSpan timeout)\r\n at Microsoft.PowerBI.EgwInstallUtils.CustomActions.RestartServiceImpl(String serviceDisplayName, String processName, TimeSpan actionTimeout)\r\n at Microsoft.PowerBI.EgwInstallUtils.CustomActions.RestartService(Session session)","RemoteStackTraceString":null,"RemoteStackIndex":0,"ExceptionMethod":"8\nWaitForStatus\nSystem.ServiceProcess, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a\nSystem.ServiceProcess.ServiceController\nVoid WaitForStatus(System.ServiceProcess.ServiceControllerStatus, System.TimeSpan)","HResult":-2146232058,"Source":"System.ServiceProcess","WatsonBuckets":null}

1: {"ClassName":"System.ServiceProcess.TimeoutException","Message":"Time out has expired and the operation has not been completed.","Data":null,"InnerException":null,"HelpURL":null,"StackTraceString":" at System.ServiceProcess.ServiceController.WaitForStatus(ServiceControllerStatus desiredStatus, TimeSpan timeout)\r\n at Microsoft.PowerBI.EgwInstallUtils.CustomActions.RestartServiceImpl(String serviceDisplayName, String processName, TimeSpan actionTimeout)\r\n at Microsoft.PowerBI.EgwInstallUtils.CustomActions.RestartService(Session session)","RemoteStackTraceString":null,"RemoteStackIndex":0,"ExceptionMethod":"8\nWaitForStatus\nSystem.ServiceProcess, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a\nSystem.ServiceProcess.ServiceController\nVoid WaitForStatus(System.ServiceProcess.ServiceControllerStatus, System.TimeSpan)","HResult":-2146232058,"Source":"System.ServiceProcess","WatsonBuckets":null}
CustomAction RestartService returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
Action ended 15:03:59: RestartService. Return value 3.
Action ended 15:03:59: INSTALL. Return value 3.
Property(S): UpgradeCode = {D430A057-BAED-421C-A12C-C4EFF28670C6}
Property(S): INSTALLLOCATION = C:\Program Files\On-premises data gateway\

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Regular Visitor

Re: on-premises data gateway install problem

I was able to resolve the issue. There was a premission issue when the install was trying to copy the \users\default user account. Somehow when the system was created another user information was copied into the \users\default user account. I deleted that user account from the default account and the install was then successful. The install log was not helpful. The Windows event log gave me enough information to resolve the problem.

View solution in original post

3 REPLIES 3
Highlighted
Microsoft
Microsoft

Re: on-premises data gateway install problem

Hi @hsnjjb

 

You may have a look at below articles to check and reinstall it. If it is not your case, you may submit a support ticket here.

 

https://docs.microsoft.com/en-us/power-bi/service-gateway-onprem-tshoot#firewall-or-proxy

https://docs.microsoft.com/en-us/power-bi/service-gateway-onprem-tshoot

https://community.powerbi.com/t5/Service/Unable-to-install-On-premises-data-gateway/td-p/106766

 

Regards,

Cherie

Community Support Team _ Cherie Chen
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Regular Visitor

Re: on-premises data gateway install problem

I was able to resolve the issue. There was a premission issue when the install was trying to copy the \users\default user account. Somehow when the system was created another user information was copied into the \users\default user account. I deleted that user account from the default account and the install was then successful. The install log was not helpful. The Windows event log gave me enough information to resolve the problem.

View solution in original post

Microsoft
Microsoft

Re: on-premises data gateway install problem

Hi @hsnjjb

Glad to hear you've solved it, please accept your answer as solution, that way, other community members will easily find the solution when they get same issue.

 

Regards,

Cherie

Community Support Team _ Cherie Chen
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
August 2020 Community Challenge: Can You Solve These?

August 2020 Community Challenge: Can You Solve These?

We're excited to announce our first cross-community 'Can You Solve These?' challenge!

July 2020 Community Highlights

July 2020 Community Highlights

Learn about the exciting things that happened in July.

Get Ready for Power BI Dev Camp

Get Ready for Power BI Dev Camp

We are thrilled to announce we will begin running a monthly webinar series named Power BI Dev Camp.

Power BI Desktop August 2020 Update

Power BI Desktop August 2020 Update

We have great updates this month! Click the link for the video with more info.

Top Solution Authors
Top Kudoed Authors