Reply
Regular Visitor
Posts: 21
Registered: ‎05-12-2017
Accepted Solution

mashup data source error in gateway (only) refresh

I have been struggling for weeks trying to resolve an error I am receiving when refreshing my dataset via a gateway (on-prem or personal).  Everything works fine from Power BI Desktop, but when published to the service and updated via demand or scheduled refresh, I get the following error:

 

Last refresh failed: Fri Oct 20 2017 08:14:26 GMT-0500 (Central Daylight Time)
Cannot connect to the mashup data source. See error details for more information.
Hide details

Underlying error code:-2147467259 Table: Story Burndown.
Underlying error message:[Unable to combine data] Section1/Story Burndown/AutoRemovedColumns1 references other queries or steps, so it may not directly access a data source. Please rebuild this data combination.
DM_ErrorDetailNameCode_UnderlyingHResult:-2147467259
Microsoft.Data.Mashup.MashupSecurityException.DataSources:[{"kind":"Web","path":"https://jira.jci.com:8443/rest/api/2/search"}]
Microsoft.Data.Mashup.MashupSecurityException.Reason:PrivacyError
Cluster URI:WABI-US-NORTH-CENTRAL-redirect.analysis.windows.net
Activity ID:52ac6557-e350-2b3f-8a7f-75b95b00c701
Request ID:786227e5-202b-7dd2-1247-5d29cc44ba81
Time:2017-10-20 13:14:26Z

 

The short description is that I have a table that is built from multiple function calls - one that retrieves a date from a table in the model, and another recursive series which executes a Web.Contents call to a REST api for Jira.  In the illustration below, the Story Burndown table attempts to retrieve a StartDate via the #activeSprintStartDate function prior to passing that date to the #"Status burndown chart" function.  This scenario results in the aforementioned error.  If I hard-code the date (see purple text below), the gateway refresh works fine.  

 

I am seeking advice on how I can separate the calls any further to prevent the error from occuring.

 

 Image.jpg

Thank you in advance,

Ross


Accepted Solutions
Regular Visitor
Posts: 21
Registered: ‎05-12-2017

Re: mashup data source error in gateway (only) refresh

Much to my dismay, the promised gateway changes that were expected to address this failed to do so and my specific issue was ultimately deemed by Microsoft as unsupported by the gateway.  My workaround was to completely redesign my approach to identifying the reporting period in a less than ideal hack.

View solution in original post


All Replies
Highlighted
Super User
Posts: 1,627
Registered: ‎07-03-2015

Re: mashup data source error in gateway (only) refresh

A new version was released today. Maybe that will fix it as it seems it was out of sync with he desktop version prior to the update. https://powerbi.microsoft.com/en-us/blog/on-premises-data-gateway-october-update-is-now-available/

* Matt is a Microsoft MVP (Power BI) and author of the Power BI Book Supercharge Power BI.
Regular Visitor
Posts: 21
Registered: ‎05-12-2017

Re: mashup data source error in gateway (only) refresh

I have updated to the latest versions of all components with no change in results.

Frequent Visitor
Posts: 15
Registered: ‎02-21-2017

Re: mashup data source error in gateway (only) refresh

I'm having the exact same problem as this, did you manage to find a solution?

Regular Visitor
Posts: 21
Registered: ‎05-12-2017

Re: mashup data source error in gateway (only) refresh

Much to my dismay, the promised gateway changes that were expected to address this failed to do so and my specific issue was ultimately deemed by Microsoft as unsupported by the gateway.  My workaround was to completely redesign my approach to identifying the reporting period in a less than ideal hack.

Frequent Visitor
Posts: 7
Registered: ‎05-18-2017

Re: mashup data source error in gateway (only) refresh

This is still an issue.  We're receiving the same error today.

Gateway and Power BI desktop are both updated.

Frequent Visitor
Posts: 14
Registered: ‎06-21-2018

Re: mashup data source error in gateway (only) refresh

Hi all,

 

I had a call with Microsoft, they asked me to put privacy level to PRIVATE in the desktop, re-publish, then set privacy = PRIVATE in the PBI online service too (in the gateway settings we're using).

 

It solved the issue.

 

Cheers,

 

F.