cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

incremental refresh - not available, parameters not showing in custom date filter

Hi,

 

I'm trying out the new incremental refresh feature on a SSAS import datasource, but it's not available.

 

I Created the parameters RangeStart and RangeEnd, but when I try use them on the date column in the dataset, for custom filtering, they're not showing. 

 

I am a premium user, I have updated to may build and I have activated the incremental refresh in options.

1 ACCEPTED SOLUTION
Anonymous
Not applicable

I found the error. the datefield must be date/time, not just Date. 

View solution in original post

15 REPLIES 15
sdesarda
Advocate I
Advocate I

I struggled with the same issue and found out the cause. You have to use both RangeStart and RangeEnd parameters and the parameter names have to be "RangeStart" and "RangeEnd" only.

Thank you so much @sdesarda ! It works, finally Smiley Happy It is a miracle Smiley Wink

Anonymous
Not applicable

This worked for me..Thanks for the solution

Anonymous
Not applicable

I was having the same issue but after I changed from direct query to Import, now I can set up the incremental refresh.

But I dont see it mentinoed as a requirement in the documentation here https://docs.microsoft.com/ja-jp/power-bi/service-premium-incremental-refresh

 

Does this only work for Import but not for direct query ?

That would really suck though

Anonymous
Not applicable

@Anonymous 

'Direct query' queries the database and brings back all relevant data, so incrememntal refresh would not make sense.

Only when importing the entire table/source and adding in new data does it make sense

Had some troubles, but this topic helped out. Date/Time format in the Query Editor was also my issue. 

 

Thanks

Anonymous
Not applicable

I found the error. the datefield must be date/time, not just Date. 

View solution in original post

v-qiuyu-msft
Community Support
Community Support

Hi @Anonymous,

 

Please ensure you already enabled the "Incremental Refresh Policies" preview feature in desktop. 

 

Also please ensure the column you would like to set custom filter is Data/Time type. For more information, please refer to this article: https://docs.microsoft.com/en-us/power-bi/service-premium-incremental-refresh

 

Best Regards,
Qiuyun Yu 

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable

I have enabled the incremental feature in preview features as mentioned.

 

I get the incremental refresh option when I right-click on the table, but it is off, and I can't enable it in the dialogbox. It says that I have to add paramaters to the dataset filter, but this has been done.

Anonymous
Not applicable

this is how I have set it up

 

Added  parametersAdded parameterssc1.PNG

after creating parameters you need to apply these parameter on any column of a sepecific table in query editor mode.

once done you will able to set incremental refresh on that specific table only. 

 

Anonymous
Not applicable

I already added the custom date filter, using the parameters I have created to the Date columns in the table (field is called dato). (See the printscreen I've added earlier).

are you creating incremental refresh on the same table which has been filtered through custom filter. i.e. SSAS Leveransepunkt. because incremental refresh will not work on any other table which has not been filtered through custom filter with parameters.

I am having the same issue.

Preview feature on, RangeStart and RangeEnd parameters defined on table, applied to Date/Time variable, but in the Incremental Refresh box for the same table shows the toggle as "off" with the warning showing that parameters need set up.

Anonymous
Not applicable

I have enabled the incremental feature in preview features as mentioned.

 

I get the incremental refresh option when I right-click on the table, but it is off, and I can't enable it in the dialogbox. It says that I have to add paramaters to the dataset filter, but this has been done.

 

 

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

November Power BI Update 768x460.png

Check it Out!

Click here to read more about the November 2021 Updates!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.