cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
DPA Frequent Visitor
Frequent Visitor

disable dialog box

Every time I open a Power BI document with an R script visual I get a dialog box - "Enable script visuals".

Is there a way to disable this or save my selection so that the program won't ask me again?

 

Thanks!

 

1 ACCEPTED SOLUTION

Accepted Solutions
Moderator v-yuezhe-msft
Moderator

Re: disable dialog box

@DPA,

There is no such option. And I am unable to reproduce your issue. Would you mind sharing me the PBIX file so that I can test? You can share the PBIX file via Private Message.

Regards,
Lydia

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

4 REPLIES 4
Moderator v-yuezhe-msft
Moderator

Re: disable dialog box

@DPA,

Based on my test,  the "Enable script visuals" dialog box only appears the first time I open the PBIX file, after I save all the work in the PBIX file, the dialog doesn't pop up the next time I open PBIX file.

Regards,
Lydia

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
DPA Frequent Visitor
Frequent Visitor

Re: disable dialog box

Thanks Lydia.

When I open my work, however, the dialog box does appear if there have been a few hours into my saving the work, it also does appear the first time I open the file on a new day.
I was wondering if, like with the macros enabled workbook in excel, there could be an option to save the BI document in a special format so as to not enable the script every time it is opened.
Moderator v-yuezhe-msft
Moderator

Re: disable dialog box

@DPA,

There is no such option. And I am unable to reproduce your issue. Would you mind sharing me the PBIX file so that I can test? You can share the PBIX file via Private Message.

Regards,
Lydia

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Highlighted
john_dawson Frequent Visitor
Frequent Visitor

Re: disable dialog box

I got round this by setting "Web Preview Warning Level", in Security Options, to "None"

Helpful resources

Announcements
New Topics Started Badges Coming

New Topics Started Badges Coming

We're releasing new versions of the badge that everyone's talking about. ;) Check your inbox for notifications.

MBAS 2020

Save the new date (and location)!

Our business applications community is growing—so we needed a different venue, resulting in a new date and location. See you there!

Difinity Conference

Difinity Conference

The largest Power BI, Power Platform, and Data conference in New Zealand

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

Top Solution Authors
Top Kudoed Authors (Last 30 Days)