cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
vozniak
Helper I
Helper I

decimal places in matrix

I have a number of Matrix visualizations drawn from measures that are showing whole numbers with two decimal places. I need to remove the decimal places. How do I remove the decimal places? I can't do it through the Modeling menu from Table view because the measures don't show in the table. I can't do it through the Modeling menu in the report view because the formatting options are grayed out. How do I remove the decimal places?

2 ACCEPTED SOLUTIONS
rajendran
Community Champion
Community Champion

Ok, In the report view, Select or click on the Measure from the Fields , Then got to Modelling , change the format as required. It should be enabled.

 

I guess earlier you didnt select the Measure in fields before navigating to Modelling, thats why it would have been Greyed out.

 

Thanks

Raj

View solution in original post

Hi @MarkSL

 

No I've not found a fix for it. I've just lived with having the 2dp.

To me its seems its something MS should fix

 

Stuart

View solution in original post

12 REPLIES 12
StevePBennett
Frequent Visitor

** For specific numbers of decimal places - As per rajendran's comment above - I've added the step (Select your Value Column), I didn't notice you could set for each value differently at first. So...

Go to the Visualizations -> Format tab- > Go to Field Formatting-> Select your Value Column (1st drop down) There is a parameter lower down 'Value decimal places'.
Make the changes here. Just type a number into the field. 


** For Zero decimal places - Edit the query and right click the header of your data column -> Select Change Type -> Select Whole Number.


Hope this helps.

rajendran
Community Champion
Community Champion

Go to the Visualizations -> Format tab- > Go to Field Formatting-> There is a parameter 'Value decimal places'. Make the changes here.

 

Hope this helps.

 

Thanks

Raj

Value Decimal Places in Field Formatting is set to Auto and grayed out so I can't change it.

rajendran
Community Champion
Community Champion

Ok, In the report view, Select or click on the Measure from the Fields , Then got to Modelling , change the format as required. It should be enabled.

 

I guess earlier you didnt select the Measure in fields before navigating to Modelling, thats why it would have been Greyed out.

 

Thanks

Raj

View solution in original post

I had to double click the Measure in the fields and then go to Modeling to get teh format option! Thank you!!!! Cat Happy

Thank you. I had the same issue. Modeling tab wasn't allowing me to change the decimals on a Measure. Didn't realize you can't just highlight the field by clicking on it, have to CHECK the box next to the measure in order to view the Modeling Tab and update the formatting. Appreciate posts like this for newbies like me who have no idea if 'it can't be done' or 'operator error'. 🙂

the modeling tab doesn't change any of my data. the decimal places is stuck on auto.

I can't get this to work completely.

I can set any number of decimal places above zero.

But if I set decimal places to Zero it displays 2 decimal places!!

 

This only happens when I set the field to average.

If set to sum then it works OK

Hi @stuartpearson,

 

Did you find a fix for this?  I am using a Matrix and selecting Average but the result is defauting to 2 decimal places and I want none.  Going into the modelling tab will only allow me to go down to 1dp, changing it to zero results in 2dp as you have also found.

 

Thanks

 

Mark

Hi @MarkSL

 

No I've not found a fix for it. I've just lived with having the 2dp.

To me its seems its something MS should fix

 

Stuart

View solution in original post

I have the same problem, with average in matrix.
3DP set --> 3DP shown
2DP set --> 2DP shown
1DP set --> 1DP shown
0DP set --> 2DP shown --> Why? Maybe some DAX can help...

Lizzi
Frequent Visitor

Not a nice solution, but I added a measure = AVERAGE(column) and there "No calculation" is selected and 0 decimals works, it gives the proper number too.

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

November Power BI Update 768x460.png

Check it Out!

Click here to read more about the November 2021 Updates!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.