cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper V
Helper V

Re: date format in slicer

@Greg_Deckler 
   I am still facing issue wherin date in the slicer is changing to mm\dd\yyyy no matter what i do. I have changed system level language to english(UK), brower (chrome & Microsoft edge) language to English (UK), Still no luck. Any other way around for resolving this. Other than date in slicer, all dates in my reports are in dd-mm-yyyy fomrat. Its really annoying and frustrating that i cannot allign the date format of filter to the rest of the dates.

Regards,

Hemant

Highlighted
Resolver I
Resolver I

Re: date format in slicer

Hi @hemantsingh 

 

Can you check if you have changed the language and spell check both to English (UK) in the Chrome browser settings?

After doing this the date in slicers should be formatted as dd-mm-yyyy.

 

Hope this helps!

 

Regards,

Suguna.

Highlighted
Super User II
Super User II

Re: date format in slicer


@bidevsugmen wrote:

Hi @v-qiuyu-msft 

 

The approach of changing the language to English (United Kingdom) works fine on IE and Firefox, but does not work for Google Chrome.

 


Chrome has it's own internal regional settings for some reason so you have to change it independant of the OS settings

 

see http://geekswithblogs.net/darrengosbell/archive/2019/03/01/fixing-incorrect-date-formats-in-power-bi...

Highlighted
Regular Visitor

Re: date format in slicer

@d_gosbellIn Power BI desktop my date format is not being picked up. Local date format on my Windows 10 = dd/mm/yyyy, but in my Power BI slicer on a Date field, it still is mm/dd/yyyy. Any clues which other setting could be influencing this?

Highlighted
Super User II
Super User II

Re: date format in slicer


@nickvanmaele wrote:

@d_gosbellIn Power BI desktop my date format is not being picked up. Local date format on my Windows 10 = dd/mm/yyyy, but in my Power BI slicer on a Date field, it still is mm/dd/yyyy. Any clues which other setting could be influencing this?


Power BI Desktop should be using the settings defined in the File > Options dialog. Note that there are "Regional Settings" both under "Global" and "Current File" so check both of those. It could be that someone set the file to use a different locale.

Highlighted
Regular Visitor

Re: date format in slicer

Thanks for replying. Solved the problem Sorry that I did not think of this 🙂

Helpful resources

Announcements
Get Ready for Power BI Dev Camp

Get Ready for Power BI Dev Camp

Mark your calendars and join us for our next Power BI Dev Camp!.

Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Tech Marathon

Maratón de Soluciones de Negocio Microsoft

Una semana de contenido con +100 sesiones educativas, consultorios, +10 workshops Premium, Hackaton, EXPO, Networking Hall y mucho más!

Top Solution Authors
Top Kudoed Authors