cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
urpalani
Helper II
Helper II

date format in slicer

Hi Folks,

 

I am using Slicer for Date and it is displaying in mm/dd/yyyy , Even though i change in formatting ,still in display it is showing as month as first ,

 

Anyone have any idea,

Capture.PNG

 

 

 

 

 

 

 

 

 

1 ACCEPTED SOLUTION
v-qiuyu-msft
Community Support
Community Support

Hi @urpalani,

 

The date format display in the slicer visual decided by the local client Regional settings. Please make sure your region setting like below:

 

q6.PNG

 

q7.PNG

 

Best Regards,
Qiuyun Yu

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

18 REPLIES 18
siimloitme
Regular Visitor

I have tried evetything.  

Changed regional settings. Changed date formats. Changed locale. etc. 

 

I need my format to be on slicer DD/MM/YYYY  and calendar should start with monday. 

 

But it ise still MM/DD/YYYY and starts with Sunday. 

There is no logic.  

When I changed my date format in power bi the the same formar should be on all the visualizations. 

In table I have it in correct format but in slicer not.    WTF?

 

 

 

This can also be influenced by settings in the browser. I have a post here on my old blog site https://web.archive.org/web/20200111123636/http://geekswithblogs.net/darrengosbell/archive/2019/03/0... (posting a link via archive.org since the blog hoster appears to be down at the moment - one of the reasons I no longer blog there)

khregs
Advocate I
Advocate I

I remain annoyed that this date format cannot be changed in the slicer's formatting options. Many years before Power BI was even a thing, my company standardized on ISO date format (YYYY-MM-DD) for all reporting to resolve misinterpretations across our international business. Now, I create Power BI reports that are embedded in a corporate web application and am constantly asked why the slicers have the "wrong" date format. Report designers need to be able to control this sort of thing regardless of the user's regional localization settings at the OS or browser level.

v-qiuyu-msft
Community Support
Community Support

Hi @urpalani,

 

The date format display in the slicer visual decided by the local client Regional settings. Please make sure your region setting like below:

 

q6.PNG

 

q7.PNG

 

Best Regards,
Qiuyun Yu

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Thank you  v-qiuyu-msft. It is perfectly worked fine.

waltheed
Solution Supplier
Solution Supplier

@v-qiuyu-msft

 

I think the Date Slicer is not fully regional date settings aware.

- First day of week is not taken into account. 

- Short date format is not used (except in the list view) 

 

See the screenshot with my Power BI report and Windows settings. 

Capture.PNG

 

I did a few tests with changing settings, restarting Power BI and so on, but could not get a correct result. 

 

 

 

 

 

Cheers, Edgar Walther
ITsmart BI and Analytics consultant
Power BI User Group Netherlands

Hi Qiuyun Yu,

 

Thanks ,It worked in Desktop,But Still in Services it is with mm/dd format.

Hi @urpalani,

 

When you view the report in Power BI service, the slicer date format s decided by browser language. Take the IE browser as example, you can add English(United Kingdom) language. See: https://answers.microsoft.com/en-us/ie/forum/ie9-windows_7/how-to-change-language-internet-explorer-...

 

w1.PNG

 

Best Regards,
Qiuyun Yu

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi @v-qiuyu-msft 

 

The approach of changing the language to English (United Kingdom) works fine on IE and Firefox, but does not work for Google Chrome.

 

Is their any alternative for this?

 

Thanks,

Suguna Menon.


@bidevsugmen wrote:

Hi @v-qiuyu-msft 

 

The approach of changing the language to English (United Kingdom) works fine on IE and Firefox, but does not work for Google Chrome.

 


Chrome has it's own internal regional settings for some reason so you have to change it independant of the OS settings

 

see http://geekswithblogs.net/darrengosbell/archive/2019/03/01/fixing-incorrect-date-formats-in-power-bi...

@d_gosbellIn Power BI desktop my date format is not being picked up. Local date format on my Windows 10 = dd/mm/yyyy, but in my Power BI slicer on a Date field, it still is mm/dd/yyyy. Any clues which other setting could be influencing this?


@nickvanmaele wrote:

@d_gosbellIn Power BI desktop my date format is not being picked up. Local date format on my Windows 10 = dd/mm/yyyy, but in my Power BI slicer on a Date field, it still is mm/dd/yyyy. Any clues which other setting could be influencing this?


Power BI Desktop should be using the settings defined in the File > Options dialog. Note that there are "Regional Settings" both under "Global" and "Current File" so check both of those. It could be that someone set the file to use a different locale.

Thanks for replying. Solved the problem Sorry that I did not think of this 🙂

Hi, 

No alternative solution for IE and Chrome so far.

Regards,

Wesam

Hi i have similar problem in relative date slicer. In my region setting week stat from monday but in P BI slicer it start fromd sunday. How can i change it ??

image.pngimage.png

Greg_Deckler
Super User
Super User

Yep, I see the same thing. What locality are you? I'm English (US). I see the same thing. You change the date format to something like dd/mm/yyyy and in the slicer it shows as mm/dd/yyyy but in other visuals it displays as dd/mm/yyyy (like table)


@ me in replies or I'll lose your thread!!!
Check out my External Tool for Power BI Desktop! Microsoft Hates Greg's Quick Measures
YouTube Channel! Microsoft Hates Greg
Check out my latest book!

@Greg_Deckler 
   I am still facing issue wherin date in the slicer is changing to mm\dd\yyyy no matter what i do. I have changed system level language to english(UK), brower (chrome & Microsoft edge) language to English (UK), Still no luck. Any other way around for resolving this. Other than date in slicer, all dates in my reports are in dd-mm-yyyy fomrat. Its really annoying and frustrating that i cannot allign the date format of filter to the rest of the dates.

Regards,

Hemant

Hi @hemantsingh 

 

Can you check if you have changed the language and spell check both to English (UK) in the Chrome browser settings?

After doing this the date in slicers should be formatted as dd-mm-yyyy.

 

Hope this helps!

 

Regards,

Suguna.

Helpful resources

Announcements
Power BI December 2021 Update_carousel 768x460.jpg

Check it Out!

Click here to read more about the December 2021 Updates!

User Group Leader Meeting January 768x460.png

Calling all User Group Leaders!

Don't miss the User Group Leader meetings on January, 24th & 25th, 2022.

Jan 2022 Dev Camp 768x460 copy.png

Power BI Dev Camp- January 27th, 2022

Mark your calendars and join us for our next Power BI Dev Camp!

Top Solution Authors
Top Kudoed Authors